Stable release 2.450 (2020/02/25)

Hi all,

Time for an update! Stuff all over the place, both in the ‘polish’ era and on a functional level. Thinks that stand out is screen configuration from the webpage and support for HQPlayer NAA with RoPieeeXL.

Here’s the changelog:

  • NEW: change touchscreen parameters from web interface
  • NEW: set touchscreen screen saver timeout
  • NEW: set customized color for touchscreen
  • NEW: support Pi 2 Design PI2AES HAT
  • NEW: [RoPieeeXL] support HQPlayer NAA
  • IMPROV: when LED’s are set to ‘off’ also disable the red power led
  • IMPROV: firmware update for Pi 4 USB Controller
  • IMPROV: bump Linux kernel for Pi 4
  • IMPROV: skip critical updates during boot

Web site update is not there yet, but that will follow shortly.



Just updated and it works fine. Thanks Harry!

After upgrading I lost my display.
It just shows “Connection Failure” on the display. The RPi still plays music, just no longer has a working display. I checked the settings and everything is the same as before the update. I rebooted several times - no luck.


Is the extension running?

You 'da man :wink:

That was it.

1 Like

after the update no signal is coming from my Raspi 3B through USB only Airplay works rebooted a lot, change all setting to USB but nothing telling me a connection failure in Roon app display
No sound nothing just silence … please any ideas?

thank you!

Allo DigiOne Signature to Benchmark DAC3 - I’m getting very cut outs about once every other song.

Allo DigiOne Signature to Berkeley DAC1 (1st gen, I think) - I get pops every 3, 4 songs.?. I think it triggered my am Moon W-6 to turn off.

The Berkeley setup is new with allo (was Sonos). The Benchmark has been up and running for a month with no issues until update, I’m thinking.

Just to let you know. I’ve rebooted and am going to monitor some more.

There hasn’t been that much changed. This is just RoPieee? not an XL?

Because for regular RoPieee there hasn’t been any change that can explain possible issues like yours…

Not XL.

It’s my Berkeley Alpha DAC. It pops during high resolution files.

Nothing to do with Ropieee. Something I’ll have to look into.

Ok. Clear. I’ve switched to the same setup (except the DAC) and will check as well.


I’m wondering are there any plans in the future with regards to displaying info on the screen during Spotify Connect playing?

1 Like

‘Plans’ is a strong word. It’s on the list.

1 Like

Great to know! :slight_smile:

And display information (bitrate, format) during Roon streaming ? :slight_smile:

Well, I tried multiple times to get Ropiee working on my pi with a touch screen, but couldn’t get the screen functions to work at all like they should: couldn’t get the display to display in the right orientation, and didn’t see the Roon interface at all. Just saw text.

I did have the Roon extension installed and was on the latest version of Ropieee XL. I also had the zone named correctly. Funny thing is, the audio aspects worked perfectly. But for me, using the Touchscreen was vital.
I reverted to piCorePlayer and have no issues - audio or with the Touchscreen.
When a new version of Ropieee comes out, I’ll rewrite my SD card and try again, as I’d like to use Ropieee if I can get it to work like it should.

Did you reach out? Because this is standard functionality for a loooooong time and should work.
So there is no need to wait for a new version: if you flash a card I’ll help you get it to work.


Thanks for the offer. I spent a lot of time trying to get it to work today; so give me 2 or three days and I’ll reflash the card and try again. If I can’t get it to work, I’ll let you know.

So I flashed the card again and it is working - display and all. Apparently my previous flashing of the card was somehow faulty.

Question: I have a Pi4 with latest Ropieee and a Benchmark DAC3 connected USB. When I attempt to play a stream, it appears that the data is sent in a moment with a display of the track appearing in the track progression area on remote. But alas - no sound and no sound. Ideas? Also - tried usb to Peachtree Audio DAC-X same problem - both it and the Benchmark are recognized and named by the software. What am I missing?

Additional info:
NUC i5 16 GIG ram running Rock
Pi3 with HiFiBerry works great
Streaming files from network storage, Qobuz and Tidal.
DAC3 is the headphone model
Reflashed the Pi4 several times - it is a 38 gig card.
Shows up instantly in ropieee.local and Roon