Stable release 2.535 (2020/06/21)


Last week’s release was a pretty big one. Today’s release is a small ‘maintenance-only’ release fixing some issues from last week’s release:

  • [RoPieeeXL] HQPlayer NAA won’t start in some cases
  • Prevent WiFi scan from hanging indefinitely


Stuck in the middle of the upgrade.

It’s been stuck here for about 30 minutes. I think my update got hosed somehow.

Okay figured I couldn’t hurt it by pulling the plug which I just did. Thankfully the unit came right up and is on the new version. This is the first time I have ever had an update hang the unit. It’s all good now.

Ok, it can take long, but 30 minutes is not ok.
This has been completely rewritten, so there might be some leftover issues I need to figure out.

Thanks for reporting!

1 Like

For the life of me I can not update any of my clients. It states there is an update, I press the update button and than after a few minutes it prompts me to reboot. However, after a reboot it says that I am still on version 2.486. One of my clients has a screen and during the reboot, it states “critical updates found, skip” and then boots to the display. Any ideas?

Ow you’re coming from an old version…
Can you send me feedback after you tried to update? Without first rebooting?

I have sent you feedback after hitting the update button. Feedback identifier: e8500c4c834626fe

PS, I do not update as often as I would like. Usually I am a version or two behind prior to updating.

That’s weird. I see lot’s of ‘DHCP Lease Lost’ messages, resulting in not being able to resolve the IP address for RoPieee’s Repository Server resulting in not being able to download.

Can you try hooking it up to cable? Or is there something else in your infra that can cause this?


I plugged it in via wired and same result. Sent feedback: c3e89b882f3d84a7

He @John_Aiello,

Question: do you have the Alarm Clock extension running?


No I don’t. I wouldn’t know what to do with it if I had it. :grinning:

1 Like

I have two RoPieee boxes running XL, set to reboot each night. Today I happened to notice both had fast blinking indicators, which I decided after seeing this thread must be related to the new update. So I logged into the web interface…

The first, a Pi 4 Model B, Rev 1.2, was awaiting boot to complete the update; I did so via the web interface and all went smoothly to v2.535.

The second, also a Pi 4 Model B but with a Rev 1.1 board, was stuck on the same screen as shown above by John. It had been in this state much longer than 30 minutes, but I don’t know since when. I did a power cycle hard reboot and it finished the update to v2.535 and returned to the normal web interface.

I don’t know if this is helpful, but sharing my experience to add to your knowledge pool Harry. Thanks for what you do.

Regards, alan

1 Like

ok, but I can’t see you triggered the update from the web interface…

I apologize, I forgot to issue the update command when sending you feedback. Here is the new feedback number: 9138f1fb3d909730

Same boot problem,
feedback id ff6eac5a2afbcd8d


But I can’t help with this. I’m not going to try to guess what the problem is.

Weird. Did not receive it.

Today my both RoPieeeXLs received the 2,535 upgarde version painlessly. No longer than 5 minutes with reboot. (Different devices in different ways: RPI4 ethernet, RPi3 WiFi). Thanks for the professional upgrade.
Maybe a new SD card with a fresh image would help. . .

A little additive to see if it helps. The raspberries.

I just updated two RPi4’s with no issues. Thanks.