Stable release 2.566 (2020/07/25)


Just before the holidays a new release :wink:

This one is fairly XL centric: the main feature in this release is support for hardware mixers on certain HAT’s that support hardware volume control (mainly DAC HAT’s).

With ‘certain’ I mean that those HAT’s are whitelisted in RoPieee as each HAT device has it’s own mixer channel which is difficult to detect automatically. This means that for now the list is fairly limited, but I expect to complete it quickly as I’ve added information the the feedback archive.

Here’s the changelog, which you can find on as well of course:

  • NEW: [RoPieeeXL] hardware mixer support for UPnP/DLNA, Shairport-Sync, Librespot and Squeezelite
  • IMPROV: rearrange webpage navigation for XL services
  • IMPROV: Update the Alarm Clock Extension (The Appgineer)
  • IMPROV: [RoPieeeXL] update Shairport-Sync
  • IMPROV: [RoPieeeXL] update Upmpdcli
  • IMPROV: support for IPv6
  • IMPROV: bump Linux kernel for Pi 4
  • IMPROV: bump Linux kernel for Pi 2 and 3
  • IMPROV: don’t use Ipstack for geo ip location
  • FIX: Make sure an alarm from the Alarm Clock Extension survives a reboot

One small note: I’ve seen people that do Roon-only still taking XL as in a “it’s bigger so it should be better” kinda way. It’s not. It is exactly the same, except for the additional services. If you don’t use them just use RoPieee instead of XL.



Thanks for the update, greatly appreciated. Isn’t it a lot of work maintaining two branches? Especially if XL is the same if those extra services are disabled.

I just updated two RPi4’s running XL. One is USB and one is WIFI. All is well here. Thanks.

I also ordered a screen and different case to play around with.

Hi Harry (@spockfish), thank you much for all you do and this new release. As an XL user I’m always interested in related updates. I was wondering about this…

The error message saying “hardware mixer not supported”.
Also, I have selected “Software Volume” multiple times but after rebooting the dropdown defaults back to “None”.

That said, I can indeed use Airplay and control the volume using the Tidal app via Airplay.

Just wanted to make sure these behaviors are to expected, and what they indicate.

This situation exists for both zones: 1) Dragonfly Red USB and 2) Schiit Modi Multibit USB.


Both are USB. As mentioned in the release notes hardware mixer support only works with certain HAT’s.

1 Like

Great Work! Thanks Harry.

I have udev rule working on 2.535 to put my USB DAC on standby when nothing playing.
After the update, it is not working anymore, even the file is in place on /etc/udev/rules.d
Any clue on this?
Feedback 7a93a4f1efe6b8a6
Thank you !

RoPieee does not support local changes.

Yeah, this issue with usb-power.rules bit me too, this morning. Here’s the thread in which we’ve been poking around:

If “RoPieee dies not support local changes” (my apologies for not noting this before), I suppose we have to get this into RoPieee as a global change. The question is, what change? Basically, what we’re doing is to insert a USB power rule which changes the “power/control” aspect of the USB audio device from “on” to “auto” for Topping devices. Perhaps it would be useful for other connected USB Audio class devices, perhaps even all of them. What’s your thinking on that?

I’m having an issue with RiopeeeXL which so far has been rock-solid for me. I just restarted my raspberry pi (which I believe triggered an update to this release) and now it won’t show up as a squeezebox client anymore and when using spotify connect it also isn’t connecting anymore. I sent feedback: 231de7fe9227ba5f

Possibly this is because I have a pretty old raspberry pi? Raspberry Pi 2 Model B Rev 1.1

Thanks in advance

Your output (for both services) is set to USB, but no USB DAC is connected.

1 Like

Well, they aren’t exactly 2 branches.

XL is ‘just’ a layer on top of regular RoPieee that adds the extra functionality.

Reason for this is that I’m committed to keep RoPieee as simple as possible for Roon-ies that are not familiar with IT in general and just want to play music and only use Roon.

Thx for the quick response. I have my raspberry pi connected via USB to an audioengine 2+ so not sure why it’s not being detected all of a sudden. I tried switching the USB port on the pi but this didn’t make any difference. I’ve also confirmed the audioengine speakers still work via USB to my pc.

Anything else you would suggest?

That’s weird. I did some more digging and I see that at least the input part is being detected, but the audio part not.

How is the DAC powered? And it is powered on I pressume?

Hi Harry. Th problem is that that worked on previous release of Ropieee.
I understand that Ropieee is a custom OS but is Linux in fact. The changes that we made are meant to help us to have a system that can fulfill our needs. I only need a simple answer: why this settings does not work anymore, and what changes have been made to broke this thing?
Can you answer, please?
Thank you.

That’s the problem. As is clear from the forum RoPieee does not support local changes. I’ve mentioned that multiple times, and that you’re on own when you do.

Now something does not work and you want me to look into it. Sorry, won’t do.

Hi @Bill_Janssen,

I’ve added it to the list to be implemented.
Problem with this setting is that if you set it to ‘auto’ it messes up quite a few DAC’s, so it need to be a setting in the advanced setting.

I’ll keep you posted, will probably land in beta first so it can be tested.


1 Like

Thank you for your answer.
I’ve just wanted to know what was changed that broke that thing.
I repeat, is something that worked well before latest Ropieee update.
Maybe is a kernel or other issue.
I appreciate your work, but, unfortunately I am not comfortable at all with this attitude.
I consider I did not do anything that can offense you.
All the best !

Later edit:
I have just saw your answer to @Bill_Jansen and I am looking forward for this feature.
Thanks !

Well, than we can shake hands, because I’m also not comfortable with ‘this attitude’.

Without recognizing my statement on local changes what so ever you keep on telling me that it worked on the previous version. Which does not make it any more valid.

If you want to make local changes because you want to tune stuff then maybe RoPieee is not your ideal solution. There are other solutions that are meant to be treated as just a regular Linux system, RoPieee is not.

You may not agree with this, that’s fine. But I do hope you recognize that I’m in charge of my own time and how I spend it.

In the mean time another forum member just simply asked if this can be implemented as feature, which I already responded positively to.



Yes, you are right. It is your work and your time, and I respect that. I don’t want to argue and I really like Ropieee.
Like I said in the edited post, I saw your answer, and I appreciate it.
So, we can shake hands anytime !
However, we have to be care now because of this pandemic :unamused:
Best regards !