Stable release 2.573 (2020/08/06)

Hi,

Small “holiday release” :wink:

It fixes an annoying issue for some users with a non-playing Shairport (Airplay) due to a problem with service discovery. Furthermore it adds the possibility to enable USB power auto suspend for connected DAC’s.

Here’s the changelog for completeness:

2.573 (2020/08/06)

  • NEW: support for USB power auto suspend
  • FIX: [RoPieeeXL] sometimes Shairport-Sync stops immediately after starting to play

Enjoy!

5 Likes

Hey, thanks for this! I’ve got my Pi4 running this now and have enabled the USB power auto suspend. After how long would the auto suspend kick in?

Thank you - I was having an issue with Airplay , and now I do not.

Thanks again

David

It’s a 2-second delay after the use stops.

Many thanks - i’m updating now… :blush:

Hi! Just updated to 2.573. I’m not a super experienced ropieeexl user so this can most certainly be a user error… But for some reason I don’t seem to get native DSD with my Nuprime uDSD dac after upgrading. DOP works fine. Cannot tell when this behavior appeared because I might have made upgrades to ropieeexl without playing anything on these versions. But it used to work in native mode ‘earlier’ :slight_smile:

Thank you so much for adding USB power auto suspend! I posted here when I first setup RoPieee since my DAC would start playing “DSD” (i.e. noise) after a stream finished and thought something like this was missing, and it’s working great with my Topping D30.

A user dependent “USB power auto suspend” kick in time would be nice :wink:

Future release option?

@spockfish , I re-installed one of my RoPieee devices today, and I am observing an odd result in the Devices tab. From the device itself, it reports the loopback address for some reason:

But, on any other Devices tab it displays the correct IP address:

Is this simply a blip in the mDNS discovery, or is something else going on?

Feedback, in case it is useful: e3ef27486edd7430. Sorry about the extraneous log entries.

A few reboots to set the clock colour, and now the IP address is fine. False alarm. Sorry @spockfish.