Stable release 2.573 (2020/08/06)


Small “holiday release” :wink:

It fixes an annoying issue for some users with a non-playing Shairport (Airplay) due to a problem with service discovery. Furthermore it adds the possibility to enable USB power auto suspend for connected DAC’s.

Here’s the changelog for completeness:

2.573 (2020/08/06)

  • NEW: support for USB power auto suspend
  • FIX: [RoPieeeXL] sometimes Shairport-Sync stops immediately after starting to play



Hey, thanks for this! I’ve got my Pi4 running this now and have enabled the USB power auto suspend. After how long would the auto suspend kick in?

Thank you - I was having an issue with Airplay , and now I do not.

Thanks again


It’s a 2-second delay after the use stops.

Many thanks - i’m updating now… :blush:

Hi! Just updated to 2.573. I’m not a super experienced ropieeexl user so this can most certainly be a user error… But for some reason I don’t seem to get native DSD with my Nuprime uDSD dac after upgrading. DOP works fine. Cannot tell when this behavior appeared because I might have made upgrades to ropieeexl without playing anything on these versions. But it used to work in native mode ‘earlier’ :slight_smile:

Thank you so much for adding USB power auto suspend! I posted here when I first setup RoPieee since my DAC would start playing “DSD” (i.e. noise) after a stream finished and thought something like this was missing, and it’s working great with my Topping D30.

A user dependent “USB power auto suspend” kick in time would be nice :wink:

Future release option?

@spockfish , I re-installed one of my RoPieee devices today, and I am observing an odd result in the Devices tab. From the device itself, it reports the loopback address for some reason:

But, on any other Devices tab it displays the correct IP address:

Is this simply a blip in the mDNS discovery, or is something else going on?

Feedback, in case it is useful: e3ef27486edd7430. Sorry about the extraneous log entries.

A few reboots to set the clock colour, and now the IP address is fine. False alarm. Sorry @spockfish.

I have also just notice that the native DSD option for the Nuprime uDSD dac has now disappeared!

@spockfish Please help!


I’ve missed @Anders_Karlsson post, sorry for that.

Can you test this again by switching to the beta channel? You can do this on the advanced tab of RoPieee’s interface.



Tried this but doesn’t appeared to have worked!

Provided feedback. Here’s the unique ID: f2c39eb4abe634e5

Best Regards



Tried switching back to stable and back to beta but still no Native DSD.

Let me know if you need anymore more info. Would be great to get back Native DSD.

Best Regards


I’ve got all the info I need (and found the issue why this is gone).
Expect a new beta release this week that should fix this.


That’s fantastic, thanks so much :metal:

@Guy_Brown1 this has been fixed with an update in the beta channel.

Awesome, that fixed it. Thanks for the hard work :+1:

Sorry for not replying sooner :relaxed: Just want to acknowledge that it works for me as well. Super happy, thanks! :raised_hands::blush: