Stable release 2018/09/01 (170)

Hi,

Quick release that fixes one thing for those that use a display: support for CJK texts.

Enjoy!

2 Likes

Yes!!
Thanks Harry, thanks V170.
Osamu SHIOTANI

3 Likes

I’m getting strange behaviour with the updates of my RPi based DACs running RoPieee on my home setup.

The Audiophonics RaspTouch I-Sabre ES9028Q2M is on the beta update channel and reports…
Package - Version
ropieee - 20180909-4
ropieee-version - 169-1
ropieee-web - 20180729-3
linux-raspberrypi-dsd - 4.14.66-2
qt5-base-ropieee - 5.11.1-3
qt5-declarative-ropieee - 5.11.1-3
qt5-graphicaleffects-ropieee - 5.11.1-3
qt5-quickcontrols2-ropieee - 5.11.1-3
qt5-xmlpatterns-ropieee - 5.11.1-3
ropieee-remote - 20180819-1
ropieee-touchui - 20180909-1

Two of the HiFiBerry DAC+ Pro units on the stable update channel both report…
Package - Version
ropieee - 20180909-4
ropieee-version - 170-1
ropieee-web - 20180729-3
linux-raspberrypi-dsd - 4.14.66-2
qt5-base-ropieee - 5.11.1-3
ropieee-remote - 20180819-1

But another HiFiBerry DAC+ Pro unit on the stable update channel reports…
Package - Version
ropieee - 20180901-2
ropieee-version - 160-1
ropieee-web - 20180729-3
linux-raspberrypi-dsd - 4.14.66-2
qt5-base-ropieee - 5.11.1-1
qt5-declarative-ropieee - 5.11.1-1

It would seem that for some reason this last device isn’t updating. What could be the reason for this?

@spockfish Hi Harry just updated and its broke for me. It not launching the screen properly so I get no now playing or controls just Ropieee is running message. I have also reflashed as the initial update got stuck in a NTP loop. Any help appreciated. I also note that it takes ages for the network to start almost 2 mins its done this for the last 3 versions so no idea why this is the same on wired or wireless. Also tried a different pi and still the same.

feedback sent 0c532c725da3599e

@spockfish Same situation here, just downloaded and flashed v170, unfortunately no album art and controls not working.

Feedback sent: 88730c50ec4e054b

Update: My apologies, I had not correctly set the “Roon control zone”. It’s working now!

1 Like

The 2 minute thingy is something I’ve already identified.

For the rest I don’t see weird things, except that you did not configure the Roon zone to be controlled in the settings.

I have though.

ok. But is it running now? Or still no display/only text?

No it’s not working. And it didn’t work before I reflashed either so that was just a regular update. Before I updated to 170 it was fine. Previously on 160.

ok. can you send me new feedback?

My Pi + Display + DAC Combo refuses to update past version 165. I tried multiple reboots.
My other ropieee installations updated without problems (they do not feature a display, though).
Feedback is bd7f80ab8756bdb4

Hi @Kopftelefon,

I know why it ain’t updating. Problem is that I can’t fix it remotely. Are you familiair with SSH?
Then I can instruct you to fix this.

Regards, Harry

Hello @spockfish,
I know how to ssh in and I’m (mostly) able to copy and paste commands, so, yes, let’s give it a try. Thanks for your great support!

Not until Monday as away for weekend.

ok then. Login with username ‘root’ and password ‘root’ and run the following command:

pacman -Syyu

Good luck!

1 Like

@spockfish

Thanks again!

1 Like

Harry,

I have a Pi 3 B+ with a Digi+ Pro Hat and no touchscreen that is stuck on version 160.

Feedback 4c896c4a06955123

Would this command get it to update?

Thanks … Tim

Yes Tim, same issue.

1 Like

Thanks!

Now updated to version 170.

Tim

1 Like

Worked for me as well. Thanks.