Stable release 2018/10/01 (179)


I’ve put out an update with some bug fixes. Most importantly it fixes the problem of a flashing progress bar on the display if you’ve got more than 1 zone playing at the same time (@dabassgoesboomboom: I think this is the issue that you’re father ran into).

Furthermore it fixes an issue where different iFi devices use different altsets for doing native DSD. This resulted in some iFi devices supporting native DSD and other not. This is resolved now.

Now, we’re still not there were I want to be with the remote extension. I’m half way rewriting it, but that will take some time.

Oh, here’s the changelog for completeness:

2018/10/01 (179)

  • FIX: display progress bar is flashing when multiple zones are playing
  • FIX: wait longer for network connection on Pi 3 B+
  • IMPROV: bump Linux Kernel to 4.14.72
  • IMPROV: support native DSD on multiple iFi devices



@spockfish Harry, only for your information, one of my endpoints would not update. I changed the update mechanism, rebooted, et voila. The update change didn’t “stick”, but the update worked. Feedback, if readable, is: 76ed376a75acf190. Thanks, as always.

@spockfish the remote extension in 179 has just stopped working. Woke up this morning to the can’t connect to Room core . Restarted several times but it won’t connect. Removed the extension and I can see in the Roon UI its flashing on/off constantly. So can’t renable it. Ropieee is on the network as is my core as playing happily to the endpoint it’s normally controls. Will reboot core and see if that helps.

Feedback sent


Reboot made no difference :frowning:

grrrrr :frowning:

Ok. Pushed out a (small) update wrt to the extension because Roon fixed a bug last week in the extension API. This for certainly is not gonna fix all problems with the extension, for that we need to wait (or actually you have to wait, I need to work harder :wink: ) for the new one.

But please update (stable channel) and see what happens.


1 Like

Updated and its back. Thanks Harry.

I use Ropieee as a remote/now playing display for my office endpoint.

I’m having a problem where Ropieee works for awhile, then seems to stop receiving updates. The app seems to still be running, because it has the current time in the screensaver, I can wake the screen, and I can connect to the web interface.

The Roon settings show a status of “Running.”

What can I do to troubleshoot this?

Are you running ROCK by any chance?

No, just a standard Roon server, on a Mac.

ok. Can you restart that one and see if it makes any sense?
And can you send me feedback? You can find the ‘send feedback’ button on the advanced tab of RoPieee’s webpage.

Feedback sent: 3353aa7e5ddbc4eb

Rebooted the server, and Ropieee flashed through several recently played albums, then settled onto the current state of the player.

So, for now, it seems OK. Strange.

RoPieee flashed through several albums?

You mean it basically ‘replayed’ your history???

Yes, that’s what it looked like.

Just visiting the old man Harry and I updated his RoPieee Touch Displays to the latest versions and the flashing bar is now gone.

Many thanks again!

1 Like