Stable release 2019/07/29 (315)

(Harry ten Berge) #1

Hi all,

There’s a new version available: 315.

This is basically a maintenance release: no new functionality, but a lot of ‘under da hood’ stuff.
Both necessary for Pi 4 support and RoPieeeXL.

But… both are not in this version yet. So if you’re looking for Pi 4 support or RoPieeeXL I suggest you read the other threads on these topics.

Here’s the changelog:

  • IMPROV: bump Linux kernel to 4.19.60
  • IMPROV: better update notification in the web interface
  • IMPROV: improve on ‘pops and clicks’ on some USB devices
  • IMPROV: lot’s of under the hood stuff for the Raspberry Pi 4
  • IMPROV: lot’s of under the hood stuff for RoPieeeXL

For the rest… you should visit the website: https://www.ropieee.org

Enjoy!

5 Likes
(Christopher) #2

My 3b+ on wifi seems to crack/pop less now, if at all, even when streaming upsampled dsd128; good stuff! Thanks Harry

(FTBoomer) #3

First update I’ve done that didn’t require multiple reboots. Perfect!!

#4

Good job. I appreciate details polished in the UI!

(Sjee) #5

For some reason my Katana is no longer visible in Roon. I think it happend after upgrading, not sure though. Is there a possibility to downgrade to a previous version?

(Harry ten Berge) #6

No… but first question: it is still configured properly?

(FTBoomer) #7

@spockfish

a695c368525a98e8

Can’t get WiFi to show up in 315. Can you see anything from my feedback

(Sjee) #8

Yes it was configured properly. I deselected Katana, rebooted, and selected it again. No differece. I also updated to 320 which did not solve the problem. To check if Katana itself was still working I installed dietpi which works fine.

(Harry ten Berge) #9

ok. can you send me feedback so I can have a look?

(Harry ten Berge) #10

Hmmm… in the log there’s a complain the key is wrong.
Can you try enter that again in the webinterface?

Thanks

(FTBoomer) #11

OK did the key again but not showing in Roon interface. d401a1f5a01f9ebb

I can see it in my wifi but it’s not an option in the Roon settings as a selection to enable or use. I’ve made no changes, just a reboot

(Harry ten Berge) #12

Ok. Confirmed. There’s nothing wrong with your WiFi or anything.

It’s RoonBridge (the Roon component that communicates with your core) that’s going crazy (constantly crashing and restarting) hence not showing up.

I’m not sure what to do here: are you comfortable with doing some SSH stuff? Otherwise a reflash seems the only other option available.

Hmmm… ok. I might have an idea what’s going on (I’ve seen this before). I’m preparing an update that might resolve this. Not entirely sure as I can’t reproduce this, but some defensive measures could fix it. Fingers crossed.

1 Like
(Kelly McRobb) #13

I am performing a fresh install of this release(327) and I am unable to enable wifi. After enabling wifi I am not given the option to reboot nor can I enter my SSID or password.

Feedback = 42cbdc05b5c3eb79

(Harry ten Berge) #14

Thanks for spotting that.
I’ve fixed this in an update.

(Sjee) #15

Since I only had one SD-card I had to reflash RoPieee and now it works. I guess it must have had something to do with the upgrade procedure but since it’s a new install there is nothing to check anymore.
Anyway, problem solved, thanks for the great software!

2 Likes
(FTBoomer) #16

Same for me. No auto-update from 315 to 328, reflashing also.

(Kelly McRobb) #17

Much better, was able to configure wireless. Thank you!

1 Like
(Kelly McRobb) #18

Hi Harry,

Now I am back to the original problem that I had before the re-flash/install. The Roon extension functionality no longer works. I have verified that the extension is still authorized in Roon. I also tried to de-authorize and authorize without success.

03ce0b450492edd5

(Harry ten Berge) #19

Have you restarted your Roon core?

(Kelly McRobb) #20

Yes, Roon Core has been restarted.