Stable release 2019/08/11 (328)

(Harry ten Berge) #1

Hi,

I’ve put out a new release, 328.

Most noticeable feature is obviously support for the Raspberry Pi 4!

This took longer than expected because of all the changes necessary to support this board, but here it is.

Next is security. Over time people asked for ways to limit access to RoPieee, either over SSH or the webpage itself. That has been covered with this release: you can disable SSH access and you can limit access to the webpage with a password. Fairly basic, but it will cover the simple use case “I need to prevent people from making changes to it’s configuration”.

As usual you can find everything on RoPieee’s webpage: https://www.ropieee.org

Special thanks for all the beta testers that helped out in getting the Pi 4 working!

Enjoy!

10 Likes
(FTBoomer) #2

328 would not auto update for me. Doing a reflash now

(Wim) #3

Thanks @spockfish, fancy webinterface, I like it. :slightly_smiling_face:

1 Like
(FTBoomer) #4

Re flashed to 328 and all’s good again.

(Wim) #5

Just one question, My LAN RoPieees have a Devices tab that is missing on my WiFi RoPieee.
Is that by design?

(Mr Fix It ) #6

It might take a while to populate and if there is no info yet it won’t show an empty tab iirc

1 Like
(Harry ten Berge) #7

No that’s not by design. It relies on service discovery and it’s only populated if it can locate other RoPieee units then itself.

Can take a while, as this also depends on the network interface.

2 Likes
(Robert Watson) #8

It is working very well for me on my new 4 with the exception that there is no Wireless tab in Networks to configure a wireless connection. Just a Wired tab. Where am I going wrong?

Also, I have a iFI Nano iDSD Black that is working perfectly with the 4. If I can get this on Wireless, I am good to go.

(Harry ten Berge) #9

This selection is based on CPU id.

And there are more out there, so this morning another one popped up. I’m going to push out an update rather soon to address this. After that you can select wireless again.

(Guanchao Shi) #11

Same issue as u.

(Robert Watson) #12

Do you need my board ID to address this? Anything else I may be able to do to help?

(Robert Watson) #13

“With wireless (Pi 3⁄4) we only support DHCP”

That is from the Ropieee software page. Is that a temporary problem or a permanent thing? If permanent, I will need to return my PI 4 and purchase a NUC to get the functionality I want, apparently.

(Nathan Wilkes) #14

Your call, but a DHCP reservation in your wireless AP is a minute or two done once — why would you prefer to hard code a wireless interface?

1 Like
(Mr Fix It ) #15

I run all my rpi’s with dhcp and allocated addresses in router setup…much easier as I know where it will turn up if I have to reflash it or even change OS

(Robert Watson) #16

Is this what I need to do? If not, could you give me a link to the procedure, please?

(Harry ten Berge) #17

No. This is client side. Client side you have nothing to do except enable WiFi in RoPieee.

For that I need to release an update as your board is not properly recognized. After that update you can configure wifi in RoPieee’s web interface.

In your router you can then fixate the unit on a specific IP address if needed.

(Robert Watson) #18

Very good. Thanks! Donating to your cause now. I really appreciate your work/efforts on the PI/Roon interface and would love to have this fully functional for me.

(Harry ten Berge) #19

Can you go to the ‘advanced’ tab on RoPieee’s web page?

And hit the ‘send feedback’ button? I can then make sure your CPU id is covered.

(Robert Watson) #20

Done… 298da4e35a5590f8 Thanks!

(Dick Vliek) #21

@spockfish Harry, minor thing. I reflashed and am now on 331 (on a pi4). I renamed the hostname and rebooted and got this:

image

Of course I have no ropieeeXL.