Stable release 2019/09/02 (352)


A little late, but this release was out last Monday. Due to infrastructure issues this was delayed.

Anyways, fairly not-exciting release. Some prepatory work for landing Spotify support in RoPieeeXL (it’s not in this release) and native DSD support for the NuPrime IDA-16 (hint @Peter_Nordbrandt).

For more details you can see the changelog over here:



Hello @spockfish, updated 6 devices fine. I notice that the Devices tab shows all as version “unknown” now. Will time heal this?


I think so. And I hope so :wink:

After a reboot I suspect it will go away. Can you try that? Because I’ve already rebooted my units so here it all shows ok.

Harry, I tried another reboot (of all), and that didn’t seem to work. I’ll check again tonight.


Can you send me feedback of one of those units? now I’m curious :wink:


Hmmmm… that’s strange. I can read the archive.

Can you try again?

FWIW I am seeing the same ‘unknown’ also on the Devices tab of all 3 RoPieee’s

Feedback for one dd35fdedf235bcbe

@Nathan_Wilkes or @Wakajazz

Can you do a simple test?

Go into the webpage, hit the commit and save button (you don’t need to change anything) and see what happens after the configure step.


1 Like

So, that works. Thanks @spockfish !

For all:

  1. Open webpage
  2. Hit commit
  3. Hit save
  4. Agree to reboot
  5. Say yes

As I did this, each device showed up with the correct version number.

Is there any way to prompt for a save and reboot? In every other respect, the devices worked perfectly.

1 Like

After configure and save but ignoring the reboot prompt the version number now shows for the RoPieee I did the steps on.


Ok thanks @Nathan_Wilkes and @Wakajazz I know what it is.

1 Like

I’m having a problem with 352 (maybe two different problems…)
I turned on a Ropieee (Ropi8) running on a RPI 2 with a display. It updated to 352, and now roon can’t see it, although roon and ropi8 see the other Ropieee devices, I rebooted another ropieee (ropi4), and it updated to 352, and now it can’t be seen by roon, ropi8, ropi4 or any other devices.
I’m not going to reboot any others for now, to keep them working.
ropi8 also returns the following error when I click on “advanced”:
TypeError: Cannot read property ‘length’ of undefined
at /opt/RoPieee/webpage/app.js:323:14
at Layer.handle [as handle_request] (/opt/RoPieee/webpage/node_modules/express/lib/router/layer.js:95:5)
at next (/opt/RoPieee/webpage/node_modules/express/lib/router/route.js:137:13)
at Route.dispatch (/opt/RoPieee/webpage/node_modules/express/lib/router/route.js:112:3)
at Layer.handle [as handle_request] (/opt/RoPieee/webpage/node_modules/express/lib/router/layer.js:95:5)
at /opt/RoPieee/webpage/node_modules/express/lib/router/index.js:281:22
at Function.process_params (/opt/RoPieee/webpage/node_modules/express/lib/router/index.js:335:12)
at next (/opt/RoPieee/webpage/node_modules/express/lib/router/index.js:275:10)
at jsonParser (/opt/RoPieee/webpage/node_modules/body-parser/lib/types/json.js:110:7)
at Layer.handle [as handle_request] (/opt/RoPieee/webpage/node_modules/express/lib/router/layer.js:95:5)
ropi4 doesn’t do this, but isn’t running an attached lcd display.

I’m on autoupdate and am having a problem that I think may be software related. Sonos and Apple airplay and other apple devices working fine as endpoints. The rpi (Allo Sig) keeps disappearing from Roon…sometiems roon shows music playing…the incoming digital signal on the dac is lit, but no music and then it disappears.
I changed nothing ( I was away for a week)
I’ve ruled out power supply issues on the rpi…what else could it be?

can you send me feedback so I can have a look?

hmmm… this sounds like something got corrupted. Can you send me feedback?

ropiPecanPi #### b05a149204b608ea working with old version
ropi4 #### e748685b4c5b10a1 not working with new version
ropi8 - not working but the advanced tab returns error (given above)
Is there a way to send feedback from ssh?

Should I re-download and install the latest ropieee, or wait for your feedback?

The ropi8 I suggest you reflash, the other ones I’ll look at the logs first.

ropi4 is borked as well…

So… can you tell me if something strange happened? I find it strange that you have 2 units both showing signs of flash drive corruption…