Stable release 3.020 (2020/12/16)


Quick release for a quick fix:

Some people reported that their Hifiberry DAC 2 HD was not working.
In the end it was related to the earlier kernel update, but it is all good now.


Harry my RPI 3+ with Allo Boss DAC just stopped working yesterday. The unit when off line yesterday morning at 9:35. This was days after the last update. I assume the the Pi somehow went bad. Has anyone else reported this? I can’t try this update because my unit will not boot even though it lights up. Cann I download the image from the web site? Has it changed since yesterday as I downloaded the image yesterday in an attempt to fix the problem.

No it did not change.

This release is just a single fix and for those I don’t create new images.


I guess the board failure is just a coincidence. I ordered a PI 4 just a few minutes ago to try and see if this solves my problem. Kind of a bummer.

I can imagine.
So, you are saying that with a fresh SD card it still won’t work?

Correct. I tried two different SD cards and one was RoPieee and one was XL. I can see the device light up but it never gets booted. I wrote if off as a bad board.

The update tonight took out both my Allo DigiOne Sigs. The USB wifi antennae no longer works. When I connect with ethernet, the only option I see is on-board wifi. When I remove the ethernet cable, Roon can’t see it and I can’t connect via ip address.


I’m going to bed. No more music to listen to.


I’m also reporting whatever recent update taking out my RP4.

Have just downloaded a fresh image tonight and flashed an SD card. But now an hour since booting up, the device doesn’t show on my network.

I have not tried a different board (I have one lying around somewhere). But find it odd that at least two others had the same problem on the same day.

I’m not using a DAC hat. Just usb. Connected through Ethernet directly to a router. Other devices on that router connect fine, so I don’t think that’s it.

Very odd!

1 Like

@spockfish that’s three posts in a row bricked. I thought it was me but apparently others are experiencing the same thing. I am not usually a conspiracy theorist but where there is smoke there is usually fire and I am starting to smell smoke.

1 Like

Can you send me feedback?

Well, I’m looking into it, but they are not all related.

The issue Rick reported is about wifi support (external dongles) and his unit is not bricked or something like that.


Can you restart the unit and send me feedback when it’s up and running?


Sorry I was not trying to blame you. I was trying (poorly) to say that there may be an issue here. It does not make sense to me that the unit powers up but does not boot to ropieee. When I have time I plan to try another operating system to see if that does anything.

My unit is NOT bricked, I agree. It works via ethernet.

So, should I flash new image to my card and re-install? These two each have the same USB antannae and are ROCK SOLID. Great reception.

I can do tonight? If there’s anything you need me to send, I will. Is this the right path to take?

Please send me feedback. You can find that option on the ‘advanced’ tab.

I’m afraid your USB WiFi adaptor is just not supported in the latest version, hence the issue.
But send me the feedback and I can have a look.


No I know, no worries.

For testing purposes I would just tick with ‘regular RoPieee’: that saves you some time.
Are you flashing with the archive (XZ) or with the complete image?

Complete image. I tried both XL (which I had been running) and then with the non-XL version. Neither version will boot.

So the red light is burning, but what does the green led do?

Well, crud!

Can I downgrade to the last version, again? I promise never to upgrade again.

Also, my web page would look funny. It would list four or five ‘devices’ all the same with the same name, ip address and everything (each having a line). Why is that?

Not sure. It was blinking while I thought it was booting but I will check it again today and get back to you.