Stable release 3.084 (2021/02/27)


I’ve just pushed out a new maintenance release. A reasonably ‘boring release’, but I wanted this stuff out of my system.

Most prominent thing is that the Alsa DAPM timeout can be configured from the web interface.
This should provide the flexibility to cater everyone’s need :wink:

Here’s the complete changelog:

  • NEW: make Alsa DAPM timeout configurable
  • IMPROV: enable 384k support for Hifiberry DAC
  • IMPROV: fine tune the network stack
  • IMPROV: fine tune CPU scheduling
  • IMPROV: bump Linux kernel
  • FIX: setting wifi region code sometimes fails

As always, enjoy!


Hi there. I just startet to use RoPieee a week ago and it is great. I am running the latest RasPi hardware with a HifiBerry Digital + Pro hat. After updating to 3.084 the system is bricked. Flashing the SD card works, but after updating it again, thee is no access available anymore. Any hints how to solve this issue?

I just did a fresh install from the XY-image (January) and did an update without changing any setting that worked. After enabling the hifi-berry pro + hat and setting usb output to “no” and renaming the device to match my network topology the reboot hangs, resulting in a red led (permanently on) an a flashing green light (about once a second). I can ping the device, but it won`t show up in the browser.



Have you tried entering the IP address in your browser?

yes, of course. Tried several other options: Fresh install, adjusting the hat and then doing the update works. When I enter another hostname the devices wants to restart. After this restart it won’t wake up.

A complete restart of the router resultet in another ip address, now it seems to work.

So the update works, but things fail if you change the hostname?

seems so, but I think the network refresh solved it. Now it works. Thanks!

Hi Harry,

I initiated the 3.084 update on my ethernet-wired RPi2 with HiFiBerry DAC+ hat. It has been about 45 minutes and the Pi is not accessible on the network. The green LED is also still flashing at 10 Hz with the red led solid. Any thoughts?


I suggest you pull the plug and restart the unit.

I power cycled in the same configuration, and it still did not boot.

Next, I tried unplugging the HiFiBerry hat, and it booted in about a minute with version 3.084 shown. I powered down, plugged the hat back in, and it will not boot. Removing the hat again, and it boots fine.

Maybe something in the new HiFiBerry config mentioned in the release notes causes a problem with RPi 2? My board type reports as “Raspberry Pi 2 Model B Rev 1.1” on the Ropieee Information screen.

1 Like

Hmmm… i don’t think that’s the issue.

Just to be sure: when you boot without the HAT the config is set to ‘no HAT configured’?
And if you plugin in the HAT is there a difference with or without the proper HAT configured?


Thanks, as always, Harry. Update took five minutes and is working fine!

1 Like

When I boot without the hat attached, the pull down menu on the main config screen still comes up showing the HifiBerry hat, so that is how it was set for prior reboot cycles with/without the hat attached.

As another test, I set the pull down config to No Hat, rebooted, confirmed it came back up with the No Hat Config, powered down and installed the Hat again. The Pi booted, with the pulldown still saying No Hat. I changed this back to the HiFiBerry option and rebooted again (with the hat still attached), and it will not boot.

Here is a table, which is probably clearer:
Hat off, Config USB only: boots
hat off, Config HiFiBerry DAC+: boots
hat on, Config USB only: boots
Hat on, Config HiFiBerry DAC+: does not boot

Having the HiFiBerry hat is the only configuration this specific Pi has ever been used with Ropieee, and has worked fine until the 3.084 update.

Thanks for your continued efforts with this project.

Another HifiBerry DAC+ Pro user here. The upgrade killed my unit too, it won’t boot at all.

I will reflash and see what happens then.

I did a full reflash, I upgraded to RopieeeXL and configured everything in the web interface - it all worked fine until I selected the HifiBerry in the Audio HAT dropdown. It prompts me to reboot, I reboot the device, and it never comes back online.

What did you select?

Hifiberry DAC or HifiBerry DAC+/DAC+ Pro/Amp2?

HifiBerry DAC+/DAC+ Pro/Amp2

How do I get the update? It’s not showing up in the web interface for me. I’m currently on version 3.075 stable.

Since I installed Ropieee on a Pi4 USB and a Pi4/w AES2PI HAT I’ve completed three SW updates without issue. Bravo, and thanks for providing an easy way for us non-software experts to enjoy great music with a minimum of fuss.


One of my endpoints is a stable RopieeeXL 3.075 / HB Dac+ Pro, shall I pass 3.084 and wait for the next release?
Any news on this?
Thanks for your effort!