Stable release 396 (2019/12/29)


I’ve just pushed out a last update for this year with the following changelog:

  • NEW: support for upgrading USB controller FW (Pi 4)
  • NEW: show temperature and uptime in devices tab
  • IMPROV: configure wireless in one step

Configuring wireless in RoPieee hasn’t always be very intuitive as it required a 2-step aproach. That has been fixed in this release.

Furthermore a nice feature for those that run a Raspberry Pi 4 is support for upgrading the USB controller firmware. Why do you want to do that? Because it’s the USB chip that generates a large part of the (extra) heat on the Pi 4. This has been corrected by the Raspberry Pi team in an firmware upgrade. You can simply upgrade it from the ‘info tab’ where there’s a ‘USB FW Version’ field. If there’s an update for your device the ‘update’ button is enabled. Just follow instructions and you’re done.

As always: enjoy!


Brilliant…I just posted before reading this that my Pi4 was running much hotter than all my other Pi3’s

oh well another round of a gazillion updates…maybe I’ll just let them all do it overnight…but Ill do the Pi4 now…


I dont see a B396 yet but it seems to be there in B395 and updated I think OK


and after

update done…waited about 5 mins now temp is 71c… dropped about 5 degrees

Forgive me if this is a stupid question, but I’m a newbie to the whole Linux/Ropieee world. I’m running Ropieee on the latest Allo USBridge Signature. I believe that your software will update itself and that I don’t need to do anything to install build 396…it’s all automatic. Is that a correct assumption? Or do I need to reflash the microSD card with the latest software version?


I just answered my own question by going to the ropieee website and using the UPDATE button.

Hi @kevin,

You can configure different scenario’s. By default it will update (if an update is available) on reboot.
And yes, when there’s an update you can also hit the button in the web page.


Thanks…I just noticed that I can have it reboot daily or weekly with automatic updates on reboot. Clever software!


Thanks for this nice piece of fire-and-forget software. I upgraded from an older version and am pleased to see added possibility to disable ssh and password protect the web ui.

On first try I chose wrong hat. No indication of errors on web ui but no device shown in Roon. Nice-to-have feature request in here :slight_smile:

Second, I have two wired and one wireless ropieee but only the wired ones display in the devices tab. Another little request, or is this somewhat intentional?

Thanks again and best wishes to all.

That’s not intentional.

Device discovery depends on multicast though, so there are quite some things at play to make it visible. Have you disconnected the wire or are both interfaces active?

Hi Harry, (@spockfish)

Thank you for this recent update, all upgraded without a hitch and working perfectly.

A suggestion for a small enhancement… the updated devices page is great to show the temps/uptime. How about an upgrade button next to each device (if not on latest firmware)? Single click and it’s done (upgrades & reboots)

Personally I have updates and reboots set to manual and this would stop me having to hit the URL on each device to update it.


1 Like

Thanks Harry!

Updates went without a hitch :slight_smile:

Awesome thanks Harry!

Not sure if this is a Ropieee issue, but thought I’d start here just in case. After flawless behavior all day, this evening, on two occasions Roon has suddenly disconnected from the Allo USBridge Signature. It just stops playing to that “Zone” and the zone disappears from this list of available endpoints. I’m using the Roon app on my iPad and I’ve tried rebooting the Roon Nucleus+ and also disconnecting and reconnecting from the iPad. Nope. The only thing that works is rebooting the Allo, and then a minute later, it shows back up as an available audio zone, and Roon picks up right where it left off. Very strange behavior. I’m guessing it’s a coincidence that I’m running the latest version of Ropiee having updated a day ago and hadn’t had any issues with the Allo previously? And also, it ran fine for a full day on the latest software before this odd behavior. The Allo power light never went off During the sudden outages so I don’t believe it suddenly lost power from the Shanti. The first time it happened, I cycled the Shanti power supply as well. Didn’t bother the second time, just turned the Allo off and then on again and once it rebooted it showed up again on Roon. Just strange stuff.

Anyone else had any issues like this with other endpoints? I hate to think my (less than two week old) Allo is having hardware problems already. I’m stumped. Any thoughts? Anyone?

Oh, this is when streaming from Qobuz, and none of the other “zones” disappear, just the Allo. And no messages from Roon…such as LOST CONTROL OF AUDIO DEVICE…and no loss of signal from the Allo to the Ares DAC. I tested this by pulling the USB cable to the DAC at the Allo, and lights on the DAC went out and music stopped and Roon threw a LOST CONTROL message. Plugged the USB cable back into the Allo and it immediately showed up in Roon and play returned to normal.

So, no Roon error messages, electrical signal to DAC still present, yet Roon suddenly says the zone doesn’t exist and it only comes back when I reboot the Allo.

what happens if you limit to playing local library tracks

Thanks Harry! Well done! You are brilliant.

I like the feature of displaying the temperature of others RPIs that I have requested earlier.

Wish you have a prosperous year and Happy New Year!

Eric from Hong Kong

Been like this for half an hour now, is that normal?

Refresh the web page, sometimes it does not auto update.

Tried that in the end came totally out of the browser.
Now it’s scanning for wireless networks ad infinitum…

Oh dear. Perhaps a reflash might be the best thing. Is this a new installation or just an update? If a new installation then your best to have it wired for the initial install as it needs to install all the updates then switch to wireless afterwards.

Its an old one, I thought I’d try a reboot to get to the new release. It’s obviously got its undergarments in a twist.
But, it still plays so I will retire with dignity from this fight :slight_smile:

1 Like