Starting Ropieee waits very long at "... check for updates ..." even when set to "manual" ? 2dbc1c7c2d923289

Could not understand when I put “manual update” in the settings there is still a checkpoint - and as said recently this took a very long time (hence I put it on manual…
here is the feedback:


‘Manual update’ is what it is: you need to apply an update manually. But checking if an update is actually available takes place of course.

I also don’t understand why you come to the conclusion that this checkpoint takes a long time as this happens in parallel.


Thanks Harry,

OK, point understood on the check update - make sense :slightly_smiling_face:

On the waiting, well, I use a Raspberrydisplay/PI3/Ropiee/remote combination to start the DAC playing and the checkpoint makes it wait before the screen with the remote options appear …

It seems not constant - this morning it took like 20 seconds - I tried now (10:25AM) and it took 3 minutes (2:57) with WIFI and also 3 minutes with ethernet cable. So is this a server time (out) thing? Or is so much data exchanged?

thanks for taking your time to help - much appreciated! Ropieee is great by the way

PS: for next update, would it be possible to have the volume dB indication shown at start up on the display? Now i always touch the artwork once and than it will appear.


The amount of data transferred is very small while doing this check, so that should not be the case.
On my side this only takes about a second… so that’s weird.

Can you send me feedback the next time it takes a long time? Without rebooting it btw?


ok, I will Harry. ee99c80da759f477

That was the display I wrote about which took 3 minutes to pas the “check for updates”

Nothing special to be seen in the log. I’ll make it a little bit more verbose so I can see better how long it’s actually taken.

I’ve rebooted my VPS just to be sure.

ok thanks Harry. I just tried again (out of curiosity) and it took 3 minutes 24 seconds. And only after that the unit is visable in Roon. I have 3x PI-Ropieee-unit-with-display for different Roon-Zones and they all have the same “issue” and take similar time to “boot” fully . A few weeks ago that was not the case and it took only, like you mentioned, few seconds to do the check. I don’t know exactly on the day when this started - sorry

best regards,


I changed something in the code which potentially can explain it (in the past it did this step in parallel, now it waits for it to finish). Except, and that’s the weird part, the step itself only takes a few secs (not even a sec on my system). So I’m not sure why this takes soooooo long on your system. What kinda internet connection are you on?


OK, that explains one part. In regard to speed: Deutsche Telekom VDSL - I just tested speed: ping 12ms down 85Mbit up 24Mbit - should be sufficient. The three displays are around the house - one 50cm from router, other 10 meter away - both wifi and cable takes this long time

Hmmm… Not a huge difference with my connection wrt speed, so that does not explain what you see.

I’ll add some more debugging wrt this part to see what’s going on.

Thanks Harry ! I will keep you posted if anything changes over here…

Hi Harry,

not sure if it was you or me :innocent: I went back into Ropieee settings and selected the wifi SSID from scratch (after disabling first and again enabling it afterwards)

This morning at several different times, start up was as usual with just a few seconds to pass the update check.

Hope it will stay like this :slight_smile:

1 Like