Startup / Reboot of NUC takes up to 5 minutes

Roon Core Machine

Intel NUC8i5BEH i5-8259U with 8 Gb ram, 256 Gb SSD

Networking Gear & Setup Details

Wired netwerk with Netgear GC110 & GC 752X switch

Connected Audio Devices

Rose R150 streamer

Number of Tracks in Library


Description of Issue

Startup or reboot of NUC takes up to 5 minutes before I can start to play music (regardless of interface I use - ipad / windows pc / iphone)

This used to be much faster.

Have you tried hooking up a monitor to see what’s going on? Might be a message timing out during that five minutes??

During that five minutes, are you able to connect to the WEB UI at all? If not, then there is a possibility that you could have a damaged SSD.

You’re right, it’s a new behavior, I’ve noticed the same. I imagine it’s checking the database and/or disk(s), while showing an animated jelly fish in the controller. As long as it come up!

I just rebooted my NUC/ROCK and it only took about a minute for Roon to start-up.
I wonder if it is library size related (mine is only 22K tracks)? or network speed related (240Mb up and down)?

Are you guys running ROCK or Windows or something elase?

It’s been the same for me recently. Not 5 minutes, but quite a bit longer than usual on my i7 NUC running ROCK. Rather small library.

Not yet but is a good idea!

I’m running Roon Rock since about 4 years on the same network and have a new Qnap Nas 653d since one year where my library is stored and usually within 1 minute Rock was ready. Since a couple of months it’s slowing down and my library has not increased rhat much over that period

grasping at straws here but…
Have you tried “clean up Library” under settings/library?
or “Clear Cache” under settings/setup?
And lastly, have you rebooted everything lately? (modem, routers, switches, core machine, etc.)

I tried it all…

When I reboot remotely I see that Rock is ready in a couple of seconds but it takes up to 5 minutes before I can start to play something.

This is the screen I get for almost 5 minutes:

This morning my NAS was not even booted, just Tidal content showing.

When my NAS is booted all content is available within seconds

Since beginning of November I am facing the same with my Nucleus Plus Rev B. Unfortunately it takes up to 25 minutes instead of 5.
Checking the browser my Nucleus Plus Rev B is almost instantly online but ROON needs another 25 - 30 minutes.
On top, when running, it takes up to 2 - 3 minutes before a selected track starts.

About 260.000 tracks
Wired internet 350 Mbps download
Running for 3 years without a problem and no changes to the internet.

Tried almost everything by replacing switches, Ethernet cables, reboot all. Nothing helped.
Switched ROON to my Synology and all works fine.

On order a new M.2 SSD Samsung EVO 970 256Gb and 2x 16Gb RAM to see or this will solve my issue.

Will let you know the results.


One other thing to try is to give the background analysis some more cores. Assuming you haven’t already. It’s under settings/Library.

Beyond this I am out of ideas.

If I were you, I would try the following options (from the easiest to the hardest):

  1. Force Nucleus to reinstall by clicking the blue “Reinstall” button the WEB UI. It would take just a few minutes. no more than five minutes.

  2. Restoring your database (assuming you have an older backup).
    Stop Roon Server Software by clicking the down arrow that shows “Restart” and choose/click “Stop”.
    Rename your /Data/RoonServer folder to some name. Then restart your Nucleus from the WEB UI.
    This would start Nucleus with an empty database, but this should at least let you see if you have a hardware or a database issue. If you don’t have any hardware issue, you should be able to see your Nucleus from your remote fairly quickly. Ok, the very first time might take a while because the remote would forget your core and you need to reintroduce your remote to your core. But after that you should be able to connect to your core in less than a minute with an empty database. If that works, you could try restoring your database. Here you have two options. Restoring the latest database, or try restoring one of your earlier database. Is there any difference? If yes, you could have an issue with your latest database.

  3. If all of those above still do not work and are fairly comfortable opening your Nucleus case and have a spare NVME SSD, you could try installing a new SSD dan reinstall ROCK on it just to try to see if it fixes your problem. Once running, you can restore your database again. If that works, Roon support could then convert your ROCK back to Nucleus remotely. If this what happens, you might have a damaged SSD.

Do let us know what you try. And the results.

Best regards

I’m experiencing 4-5 minute boot cycles as well. New to 2.0 (1182).

So, it thought of something else, do all of you that are having issues have 1. Large libraries and 2. NAS storage that Roon is “watching”. @Benedikt_Gruyaert last post about the “NAS was not even booted” might Roon looking for the storage and waiting for a response that times out due tot he NAS not being on? Maybe, IF, the others that are having issues also have a NAS with large libraries there is something causing a delay in Roon finding the Watched folder??

Might be time for @support to look at logs? For one or a couple of you?

Hi, I followed your last recommendations to no avail…
Some support (@support) would be greatly appreciated :slight_smile:

Support might not chip in, because it’s a feature, not a fault. The library is now re-scanned on startup. Obviously, the larger your library, the longer this takes. Roon recommends to leave the core running 24/7 - in which case this isn’t an issue.

I get your point but before version 2.0 it was less than a minute if I remember well. Also when the NAS is not online (so nothing to re-scan) it still takes 5 minutes before I can use Tidal. The reason I switch off the NUC is for power saving with current energy prices (I live in Europe). I used to have a continuous 200 Watt power consumption for idle devices (pc’s, NAS, switches, NUC, stand-by devices…)…

To be honest, I’m not using the new features of 2.0 (Roon ARC)…

I hear you, I’m in exactly the same situation…