Static when switching to any bit-rate other than the first played

So as said in the title I’ve been having issues with major static any time I try to play a song that has a different bit-rate than the song first played when starting roon. If I switch back to a song of the original bit-rate however the static is gone and it sounds completely perfect.

After some short troubleshooting, it appears to only happen when in exclusive mode (and only within roon). I’ve tried uninstalling and reinstalling the latest drivers but the issue still persists.

My setup consists of HD 800 > Schiit Valhalla 2 > Schiit Bifrost Multibit > Connected through Realtek Optical > Roon

Any suggestions on things I could try to resolve the issue would be appreciated.

Which OS? Are you using the Realtek drivers? I went with removing the realtek drivers and using the High Definition Audio Device drivers from Microsoft and it solved all of the audio issues with Roon.

accidental edit.

I completely removed the Realtek drivers and then rebooted. Win downloaded the next best driver which was the MS HD Audio Driver.

Uninstalled and rebooted as recommended but the issue still persists using the Windows 10 drivers.

-edit: further testing it still does actually happen with any change between bitrate/frequency

This KB Article about troubleshooting dropouts may be of assistance.

I’d suggest adding a Resync Delay and seeing if that resolves things. Try 500 ms and working up or down until you find a minimum value that works.

Thanks for the link. I tried the suggested fixes and none of them worked in exclusive mode. Out of exclusive mode I don’t appear to have the issue (at least for now) so it seems to have something to do with that.

I’m running a 5820k at 4.2GHz, 32gb ddr4 2666, so I don’t exactly think I’m having hardware-related performance issues. I also tried running a set of varying format files on an ssd and the issue still persisted.

To clarify though (unless that was just the general troubleshooting page) I’m not having any kind of dropout it’s more so the music will still play I’ll just hear a large amount of distortion and static over top of it.

Let’s drop some flags for @mike and @vova to see if they can investigate further.

Can you drop a screen shot of the audio setup for this ?

Can you use any feed other than optical just to see if there is a change?

Not sure if this is what you were asking but here are some screenshots . Let me know if you would like more info.

I don’t currently know where a usb cable would be to test, but when using one before I would receive a bunch of unrelated interference and static so I swapped to optical. I’ll still try to find one though.

Found a usb to test with and had the same issue.

Would you mind to share a screenshot of the DAC settings in Roon when it is connected over USB?

Also, it is worth trying to update you DACs firmware to the latest version.

This was with a different dac but the issue occurred anyway so it seems it is not just my Bifrost. (had to use the HPA4 to test as I was having issues with Schiit’s W10 usb drivers installing correctly).

Just to rule it out though I ordered a new optical cable to see if for some reason that has something to do with it.

So, I got the new optical cable and as somewhat expected it made no difference. I’ve done full uninstall/ reinstalls of all drivers I can think of and of Roon with no luck so I’m not exactly sure what to do next.

If there are maybe some logs Roon may be creating that might have info on this issue I’d be glad to provide them. Other than that any other advice would be appreciated.

Sure, we can try to check the logs (@Eric will contact you with more details via PM). But I would still encourage you to do few other tests while logs are being analyzed.
First let’s try to move you current Roon DB aside and test this issue with a fresh install:

  1. Locate your Roon folder
  2. Rename it to something like Roon_old
  3. Reinstall Roon from our website
  4. Log in, and add your Watched Folders back
  5. Try to reproduce an issue

This is just temporary – you’ll be able to go back to your main Roon install soon, but if your issue is resolved this way, we know this is related to your installation, as opposed to something environmental.


@Rumiho ---- Thank you for providing logs to us, that information is very helpful while investigating issues. We noticed that you have ASIO4ALL installed on your computer, based on the RAAT logs you provided. We would like to see if this issue reproduces itself without ASIO4ALL engaged. To avoid having to uninstall, we suggest trying to run your “core” on another machine to see if a different result is yielded.

  • Eric

Hi Rumiho,

Take a quick peek at this thread. It might help.

I ended up just completely uninstalling ASIO4ALL to test, as I did not have another computer readily available, and was able to reproduce the issue. I am however getting a new SSD today so I was going to set up a completely fresh install of Windows 10 with roon and completely block the realtek drivers as suggested by @Rugby and linked in that thread.

Thanks for the heads up. Let us know how things are going after windows re-install. It is also a good idea to try to install Schiit USB drivers while system is clean.

Just finished loading everything onto the fresh W10 install and the issue remains so I’m not quite sure what else I could try. I would think that at this point it would not be software related.

As such the only thing I can think of would be to send in my Bifrost to Schiit to see if something went wrong somehow when they upgraded it from Uber to Multibit and they missed it when originally tested ( or at least maybe something related to the USB issues).

Granted that doesn’t exactly explain why the Fostex HP-A4 exhibits the same issue…

If you’d like though I could submit another set of logs as it may be easier to see (if shown) whatever is occurring now that it’s a fresh OS.