Steps to Upgrade Internal Storage Drive in Nucleus

Seems like an import from external drive/folder to internal storage on nucleus/rock might be a feature request worth persuing.

I already have all the music stored (in several locations) on my PC, so I have no need to copy from the old SSD.

The current SSD is 2TB and I’m replacing it with a 4TB. When I bought the Nucleus, I had no hi-res music in file format on my hard drive and my library was taking up less than 1TB. But then I discovered I could rip the DSD layer from all my SACDs (200 of them), and then I found I could rip the hi-res files from a number of album box sets I had that included music on DVDs as well as CDs, and the final nail in the coffin was purchasing a boatload of hi-res downloads.

I figure if I need to expand further in the future I can get another large capacity SSD in an external case and plug it into one of the USB ports on the Nucleus. After that I’ll have to move to a NAS, as was suggested earlier in the thread.

all good… ignore my comment about ext4 then!

FWIW The included bracket didn’t line up with my WD Blue 1TB SSD. I had to leave out the 2 screws closest to the connector.

It’s not a huge deal but that is strange. Send me model #? Those holes are really standard (or should be)!

WDS100T2B0A - Image attached. Drive holes could be slotted to fix this or spacers could be used under the bracket. It was close, but would put too much pressure on the connector otherwise.

Jason, in the picture it looks like that hole is very close to lining up. Forgive me if you’ve already done this, but have you tried attaching the bracket to the drive first, before screwing the bracket into the Nucleus with the silver screws?

When I swapped my SSD recently I found that if I set the bracket and the drive both down flat on a table top, the holes for the black screws didn’t align perfectly in the vertical direction - I had to lift the SSD up off the table very slightly to get the holes to align. Everything went smoothly after that.

Agreed. On each side, 1 hole should be round, the other slotted. We plan on doing this in a future revision.

1 Like

Danny, I have completed my SSD swap, replacing the 2TB with a 4TB. Physically there were no issues swapping the drives - I had that done in about half an hour. There were a couple unexpected things I ran across in the subsequent process however:

  1. The step by step procedure I put together needs to be modified to include another “stop server software” step after formatting the drive because the server software automatically starts up after formatting the drive.

  2. Restoring the backup went ok (took a long time!) but after I was finally able to get into Roon again, I noticed a spinning activity icon in the upper right corner of the screen. I first checked Settings, Library, to make sure it wasn’t doing Background Audio Analysis (it wasn’t). I then clicked on the activity icon and got a message that said:

“Adding music to library: Complete. Nucleus Internal Storage - Scanning now…32899 Tracks Imported, 21191 Files Scanned”

I let it sit for 10 hours and absolutely nothing changed, so I restarted the server software. The activity icon appeared briefly, then went away. I checked Settings, Library, and found that the Nucleus was now doing Background Audio Analysis on 304 tracks. After it finished that task, everything seems to be back to normal. I did however find 13 tracks that needed to be deleted in Library Maintenance.

Any idea what happened to me with those various issues?

I tried that, but it puts too much pressure on the connector if you try to tighten the silver screws. So you can either delete two black screws or put washers under the silver screws, but the silver screws aren’t very long.

Interesting. I wonder if your SSD is not made to the standard 2.5" drive configuration? On both of my Samsung 860 EVO drives, I attached the rails to the drive first, placed the drive flat on the drive mounting platform, and slid the drive into the connector. Everything fit perfectly and tightening the silver screws was not an issue as the rail was already flush against the platform.

Something that I wonder about though is that my Nucleus has a thick sheet of clear plastic covering the platform where the SSD sits. I don’t know if it’s supposed to be some kind of insulation, or to act as a spacer. Does your Nucleus have this plastic sheet? If it doesn’t, I can understand the problems you’re having with not being able to tighten the silver screw without stressing the connector.

Here’s a picture of the SSD mounting area in my Nucleus showing the plastic sheet:

We added this early in the Nucleus build runs when we found some drives had exposed circuit boards that extended past the edge of the drive itself. This sheet prevents any short circuits.

I suspected that was the purpose when I initially opened my Nucleus. I’ll have to say though that it is slightly confusing that the official drive installation page (https://kb.roonlabs.com/Installing_Nucleus_Internal_Storage) does not show this insulator. I wasn’t sure if it was supposed to be there or not after not seeing it in the kb procedures.

Unfortunately, I made that document with the very first Nucleus ever made.

Mine is new, and has the sheet. Thank you both for the follow-up.

Jason, re-reading everything I guess your problem is actually alignment in the vertical direction, not the horizontal direction? I was originally thinking you couldn’t get all the screws into the drive because the holes didn’t match up horizontally, but that’s not the case? If I understand your situation correctly, what you would need is for the hole closest to the connector to be slotted in the vertical direction to allow alignment of the drive with the connector?

Correct. It is a vertical issue.

I used to use a QNAP NAS for my storage networked to a Roon Nucleus Plus. It backed up to a USB HDD connected to my laptop as well as to a cloud service. A couple of days ago I plugged this backup HDD into the Nucleus to compare the sonic performance and it was clearly superior in terms of detail, dynamics, clarity, timing and quite simply involvement. Suffice it to say the QNAP will now either be relegated to backup duties or sold off…

That is extremely interesting. Anyone else experience this?

I can’t say I hear a difference. I still have my Synology NAS on the network, but the library was disabled. When I put the NAS in play against the SSD in my Nuc I really don’t think I could tell a difference using Jeff Tweedy’s solo album (24/96).
But then again, I couldn’t tell the difference between these 24-bit FLACs and the MQA version on Tidal. So I may have bad ears too. Expensive ears, but just not up to par.