Still Having Problems with my Nucleus - Plug and Play? That's a laff!

Thanks to everyone in the community who has helped me so far, your support has been great. I am making progress, but there are issues that seem to not be solved by Roon’s own advice, or suggestions form the community. It’s really getting frustrating that something that is marketed as “plug and play” clearly isn’t!

Anyway, issues are…

  1. Cannot get Nucleus to link to my NAS drive. I have tried adding it as a network folder (as described in the help information). Nothing happens at all. NAS is visible in File Explorer.

  2. My Nucleus with it’s 1Tb internal storage is only visible on file explorer when I connect my laptop via ethernet cable. When you revert to WiFi it disappears? I’m not sure why that should be?

Apologies, but I am getting frustrated, particularly when there is no response or help from Roon themselves (with whom you spend a reasonable amount of money), nothing seems to work the way it is supposed, and not being “technical” I feel a bit lost at times. Beginning to regret this purchase if I was honest.

Anyway, thanks again to the guys in the community who has helped so far, anything you can suggest for the above will be very appreciated.


I see that you’ve been getting help from the community in your other threads, but now that you’ve opened this one, I will close the others, and we can concentrate on helping you here in this thread.

Your point 2 possibly indicates that you have two separate sets of network addresses in your home network - one for your wired network, and one for your wifi network.

Alternatively, this could just be one of Microsoft’s many Windows mysteries. Can you try entering \\Nucleus\ in the address field of the File Explorer when your laptop is connected by Wifi to see if it shows up?

Is SMB enabled on the NAS? On my Buffalo branded NAS it wasn’t on by default.

Thanks Geoff.

Hi Geoff, thanks for responding typed \Nucleus\ in windows explorer. Dialog box appeared stating it could “Cannot open Nucleus” with an option to run Diagnostics. Chose this, after a short time another dialog box appeared with the message “Cannot find Nucleus”


That it may be useful to copy some screen shots…


Do you have a Nucleus or Nucleus+, if it is a Nucleus+ then try \\NucleusPlus\

Keep in mind you need to have SMB1 enabled in Windows. Look at Option #1 in this post.

These screenshots were taken when you were using the Wifi connection - I see the WiFi icon in the Taskbar. And when you use a wired ethernet connection on your laptop, then you are able to connect to the Nucleus using File Explorer?

If that’s the case, then it does look as though there are two separate networks in play here. So, right-click on the WiFi icon to go to your Network and internet settings, click on properties, and tell us what the IPv4 address of your laptop connection is.

Then do the same for the wired connection - right-click on the network connection icon in the Taskbar and go to the properties to display the IPv4 address for that connection…

1 Like

Okay. Willdo I’ll get back asap


Hi Geoff,

Right providing I’ve done this right: IPv4 addresses as follows;

Wifi -
Wired -
Nucleus -


Geoff’s suspicion was correct, you have two networks going. The Wired and Nucleus are on the same network, the Wifi is a different network.

1 Like

… and Roon requires all the components to be on the same network. Can you give more details on what your network setup is?

Ah - looks as though the Bitdefender Box may be setting up a different IP address range for its Wifi network?

Looks like? Question is what do I do to fix it. I’m clueless. Honestly I’m rubbish, I can use them, but when it starts to get technical…

Inassume I need to get the Nucleus on the same network?

Honestly Geoff I dont know. I’m not very technical I’m afraid. But it certainly looks like it. I also have a Deco mesh network, so dont know if that’s doung something either?

A review of the box on Amazon includes

“In addition, in my experience, most network routers etc use the IP range to 255, with .254 normally being the router IP. The Box 2 creates a new network with range to 255 by default”

Perhaps the best thing is to tell us in detail what your network setup is - hardware and connections. Here’s mine as an example. Pencil and paper will be good enough to document it - you don’t need fancy graphics.

1 Like

Oh dear… Let’s just make things more complicated than they need to be…