Still Having Problems

Looking for any advice.Running Windows 10 Pc.Computer hooked straight to dac usb.Music on external hard drive.When trying to upsample to DSD256 with Roon and Hqplayer music that’s from Tidal plays perfectly fine with regular poly sinc filter at DSD256.When files from my music external hard drive which are 24 192 get very bad stuttering.Also can’t get Hqplayer to work on its own without Roon.Uninstalled And reinstalled Hqplayer still problem persists.When up sampling Tidal cpu only at 32%.Doesnt seem to be a PC problem.Do I have a Hard drive problem.Could it be Hqplayer.Also video card is Quadro K2000 which has cuda cores but when I click on cuda off load at any level of up sampling get bad stuttering ? Please need help.Any advice would be appreciated .Thanks

Can you post a screenshot of your HQ Player settings screen?

Upsampling to DSD256 is a heavy job, certainly for the non -2s poly sinc filters. How are other options doing? (Upsampling to DSD256 with a -2s filter, upsampling to DSD128 with any filter). If any of these options work fine, your hard drive is probably fine (ie. no problems with data transfer).

If you have a multi-core system (quad core or more), setting ‘Pipeline SDM’ will help distribute the load. Also: setting ‘Auto rate family’ will ease the load of upsampling somewhat.

I can understand upsampling to 256 is intensive,But why does it work with Tidal but not with my library.And why can’t Hqplayer work on its own ? Can’t post shots ar work.

You mention the files on your hard drive are 192/24 > even more upsampling load. If the files on your hard drive play well in Roon, you can pretty much rule out hard drive problems.

Please try the suggestions above when you get to it and report back (you can post the screenshots by just dragging them into the text reply box) – without this any call would be just blind guessing.

With Hqplayer alone I can’t get it play at any rate

Can you explain exactly how to do post a screen shot never done it before ?

Can you please describe step by step what you do when trying HQPlayer on its own,
HQPlayer must be able to play for sure on its own if it plays through Roon.

For playback HQPlayer on its own try to drag and drop the SAME files you play with Roon/HQPlayer (not from Tidal)?
Move a FLAC file from your ext HD to your system HD and try to play from there. In this way you bypass the ext connection.
Set buffer time to 100ms.
During all attempts do NOT upsample to DSD256 - it adds a variable to your troubleshooting which you don’t want at this stage. Try a simple 192 kHz. Only after everything is OK, you will try DSD64, then 128 and 256.

As it was said before, upsampling a 24/192kHz file to DSD is more CPU intensive than upsampling a 16/44.1.

Tried dragging a file from library.Tried by adding library into Hqplayer.Tried all formats.All that happens when I hit play a small box appears that says please wait while a green bar goes back and forth.And yes it does work with Roon but not on its own ? Other day was told by someone to remove xml file which I did and it worked for a little while then quit working.Cant figure out ?

I was the one who told you to remove xml file! :wink:
You don’t have to drag files from its library. You can drag files from your Explorer (where you see your whole computer) which is part of Windows apps.

Let’s do one step at a time.
Please do EXACTLY the following and report if there is a problem at any stage -

  1. Open Explorer
  2. Navigate to a folder that contains FLAC files, either on your system or external disk
  3. Drag one FLAC 16/44.1 file into the bottom window of HQPlayer; the file/song is now visible in the window
  4. Set drop down menus in the centre of HQPlayer to; Poly-sinc, NS9, 192000, PCM
  5. Hit PLAY button,

If it plays well, then move on:
6) With the same file in the window, set drop down menus in the centre of HQPlayer to; Poly-sinc, DSD7, 2822400, SDM
7) Hit PLAY button,

Still no go .Did exactly as you said same behavior hit play small screen says please wait while a green bar goes back and forth.

Also default PCM setting only goes up to 256 while my dac supports up to 384 ?

I assume that you did exactly 1-5 and you only got a progress bar. Right?!

Please tell me what you have in Settings menu as Backend and as Device.
In Backend please eventually select “ASIO”, if your DAC supports it.

Your DAC supports PCM 384 (what DAC is it, BTW?) and it has nothing to do with 256! “256” refers to DSD.
I think there is some confusion here between PCM and SDM (DSD). For the moment and to avoid confusion please keep always PCM in the far right drop down menu.

Following your steps.Set to PCM.CD Drive is D.Backend Asio.Device Moon Usb Hd Asio Driver.SDM none.Dac is Moon Sim-Audio 280D DSD.Hit play screen says please wait while green bar goes back and forth.Like I said Hqplayer works when used with Roon.Also I noticed when I hit play where it says format it is blank.

If format remains blank, it means that the files you want to play are not recognized by HQPlayer.
Do not forget that Roon converts for example MP3 for HQPlayer to play, whereas HQPlayer on its own can only playback WAV, AIFF, FLAC, DIFF and DSF.

In your settings everything seems fine.
Please try to do the following:

  • Playback a file with Roon+HQPlayer which you are 100% sure that is a FLAC or another HQP supported format;
  • then drag and drop the SAME file into HQPlayer bottom window (you must see the song name)
  • Play.
    You must be able to play the song back because HQPlayer is exactly in the same position/setting of your previous playback with Roon+HQPlayer!

My files are flac 24 192 uncompressed that were ripped by dbpoweramp from my CDs.It did work for awhile when I removed the xml file form HQ .These files worked with my Mac with Hqplayer.Could it be the Flac files are uncompressed ? I also tried dragging a dsd64 file into Hqplayer with no luck either.

There is no much point to rip a CD to 24/192 because its original frequency is 16/44.1.
It’s better to rip to FLAC 16/44.1 (uncompressed) or AIFF and let HQPlayer do on-the-fly upsampling to 24/192. It also uses less HD space.
In your case HQPlayer does not recognize such files compiled by dbpoweramp, Probably they are non standard.

I am sure that, if you re-rip a CD to AIFF 16/44.1, HQPlayer will play it back.
Please do a test too if HQPlayer supports FLAC uncompressed 16/44.1.

I will try that.I had ripped these before getting Hqplayer.But I also tried one of my DSD files that didn’t work either .

Leave DSD aside for now.
Are those native DSD files? Did you buy them online? There may be the same problem as before.
However, as I said, let’s look at them later.

When you play back the ripped files, in the 4 drop-list HQPlayer menus you will have: poly-sinc, NS9, 192000, PCM.

I just want to say a big thank you, for your help and patience .

Tried AIFF 16/44.1 and FLAC 16//44.1 uncompressed still doesn’t work ?