Stop Roon Server via Windows command line

If you are remoting into the headless server with GUI, then just right click on the RoonServer notification icon and choose Quit. It will stop all three RoonServer processes. Backup. And then click on RoonServer to start it back up.

I don’t have a Roon server notification icon in the system tray. That was the first thing I looked for when I remoted in.

Very odd. And it’s not revealed when you click the caret to show “hidden icons”?

As shown in the above screen pic. If I right click that icon in the tray it will give me the option to Quit. Are you sure you are running RoonServer or are you running Roon. Roon does not put a tray icon. The two are different install programs.

I am running Roonserver, and I do not have a notification icon. I only have the keyboard icon, audio icon, and “safely remove device” icon in the notification area. I do not even have the caret to show hidden icons.

There is no other way to shut down Roon other than right-clicking this notification icon which I can’t seem to find?

OK, I semi-cheated. I went into Task Manager’s “Startup” tab and temporarily disabled Roonserver from starting, then rebooted. I’ll enable it again after I backup the Roonserver folder.

Thanks for trying to help though…much appreciated.

OK, well that didn’t work. Roonserver is still running, even though it’s been disabled from Startup in Task Manager. WTF.

I figured out why I wasn’t seeing the hidden icon caret, and was able to turn that on, but that only hid one of the icons that was already showing. So then, my issue really is that Roonserver isn’t displaying a notification icon for me.

See this post from Steve (@scolley ) for a batch file in Windows 10 to stop RoonServer, back up the database and restart it.

I don’t know why you are not seeing the RoonServer tray icon.

RoonServer has an associated process that will restart it in the event of a crash, which is why you see it restarting.

That post you linked to essentially talks about issuing the “taskkill” command to stop the roonserver.exe process, but that has the same effect as ending the process in Task Manager…a new process pops up immediately and shows one still running in Task Manager. So “taskkill” isn’t doing the job either (see Joachim_Hebert’s post above which talked about this).

Can I kill that restart process somehow to prevent it from starting up a new server process? What’s it called?

This post from @danny sets out how RoonServer and RoonAppliance interact. Danny will see that flag and may be able to clarify how to use Taskkill, or another command, if it is no longer working.

Thanks, that was a good post to read, as I now know the difference between RoonServer and RoonAppliance. However, @danny stated in that post that killing RoonServer will immediately kill RoonAppliance, and that is just not what I’m seeing currently, so I think something has changed since then.

Steve’s batch file (suitably amended) is working fine for me in Windows Server 2012 R2. It closes RoonServer, copies the database (I amended it to database only) to a USB stick and restarts RoonServer.

How are you killing it? And on what platform?

I’ve tried several ways…via “end task” in Windows Task Manager. Issuing ‘taskkill /f /im “RoonServer.exe” /t’ in a command shell, or by ending the task in Process Lasso. In all cases, the task is killed and a new one (with a different PID) is spawned.

I’m on Win10.

EDIT: I should also point out that my Win10 installation was first optimized by Audiofile Optimizer V2.0. I shouldn’t think that anything AO did would affect my ability to kill the RoonServer task, but I thought I’d mention it in case someone knows different and can provide an explanation.

well, thats a pretty evil kill… you should shut it down, not kill it forcibly where it has no chance to do anything (like shutting down roonappliance).

OK, so I don’t know why I didn’t try this earlier, but “stopping” the service from the Services tab of Task Manager (rather than trying to “end task” it from the Processes tab, worked.

Hi roon: Please give us a switch to shutdown roon server, like roon server /shutdown, that behaves just like the function offered by the tray icon. Everything else just doesn’t help.

I’ve opened a ticket to get this done, guys. Stand by!


Sounds great, would be really helpful in setting up an automated backup process.

1 Like

ok, we are adding this to the upcoming api, but the right way for you on windows is to just kill RoonServer.exe

This should work:

taskkill /im RoonServer.exe /f

you might need to add a /t option to the end if it keeps RoonAppliance.exe lingering around.