Stopped Playing Too Many Errors - Euphony OS

Hi Henry,

Yes I have also the same issue. Roon now and then skips the first track and shows the warning. Going back to the first track always works.

This afternoon I installed Roon remote on an old Android tablet to see if I also get the same warnings. It did, so no difference with my Ipad.

This morning I discovered Euphony had a new update. After installing it the failure persisted.
Do you get the “not available” warning when you play music from Euphony Stylus?

My question to Roon support: Can it be Linux related? Tom, Henry and I have all three a linux based system.


Hi Eric,

Just another fellow user with a couple of comments. Sent direct so as not to intrude on nuwriy’s questions.

You mean can it be Euphony related, as Henry can run ROCK just fine (which is also based off Linux), and I have no issues using basic Linux or ROCK. And, the answer is yes it could. It could also be network related, including ISP, network Hardware, etc etc. I am assuming you are not running VPN software on the network.

BTW, the error message has nothing to do with the remote in use, so using an old Android tablet doesn’t tell you anything as the issue is between internet and Core.

Well, symptoms may be the same, but, the solutions can be different.

I would suggest isolating the issue:

  1. Turn of the Euphony machine. Run Roon on a different machine with a different OS on your network. Test Tidal playback. If that works, then you know it is something with the Euphony machine. If it fails as well, then it is probably something with your network.


Hi Eric,
I am never going to be a Stylus user so I haven’t tried it. As I do have ROCK on the M.2 card and Euphony on USB I have switched and the problem does not happen on ROCK. Same machine, same configuration. I also think our issue is distinct from that of the OP so maybe a different thread and maybe raise a case with Euphony too.

Hi Daniel,

it’s not my intention to intrude on anybody’s questions. I am a newbee here and have Roon for a month or two now. I am very satisfied with Roon and the first weeks of use everything worked without any failure. In a certain moment both Roon and Euphony were updated. Probably after these updates the failure showed up. Of course the software of Euphony can be the cause and I will ask the same questions in the Euphony thread. It’s just my goal to get rid of this somewhat annoying problem and to help others with the same problem with my experiences. Together we are stronger than alone.

In Euphony you can choose to play your music just with Roon without Euphony Stylus endpoint. I will try this today and will report about that.


1 Like

I too have in some way the same problem. I have a self-build server/streamer with a Xeon processor and 16 GB of memory. My OS is Euphony with Roon core integrated. I use Tidal for streaming my music. I still can play music on Roon but I get repeatedly the “this track is currently not available from Tidal” on the screen of my Ipad. A second or third attempt to play the song is mostly succesfull. I have the problem for some weeks and tried to find the cause. I once logged out from Tidal and tried to log in again but Roon did not accept my password anymore. I restarted everything but to no succes. My password was not accepted. I finally put back my last backup and then it worked again. My problem is not as big as Tom’s but still it is annoying that songs won’t play immediatly and you have to try several times to start them. Euphony has it’s own player, called Stylus. When I play with Stylus and stream from Tidal I never get this problem so it seems Roon related. I am a new Roon member but I have seen that this problem occurs from 2017. It seems that the cause of these problems is never found.


1 Like

@Eric_Megens I am evaluating Euphony on an i7 NUC and have experienced that same issue. It is running off a USB3 memory stick so not an optimum installation but my only issue with it is that the first track can return a not available warning. Selecting it again works. I can run ROCK on another NUC and Tidal works fine.

Hi Eric,

Sorry, my reply was meant to be a private message. I have moved your posts and their replies to their own support thread. Roon support wants to engage each user/issue independently. While people may have similar symptoms. The cause and solution can be different.


Hi all,

the problem seemes solved. After all it was a network problem. A few days ago my ISP installed a fix on my modem probably due to more complaints from other customers. That worked. From that moment only one single error did appear but in the last two days everything went right. It remains strange that playing music from Tidal with Euphony Stylus was flawless but playing music from Tidal with Euphony Roon caused a lot of errors. I guess I will never know. I somewhere read that Roon approaches Tidal in a different way than Euphony does but I don’t know if that is true. If so, it could be explain the difference. I am glad it is solved (hopefully).


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.