Storage loses NAS after network problems

Roon Core Machine

Synology NAS (415play)

Networking Gear & Setup Details

I have a Ubiquiti network with a Dream Machine Pro, USW-24-PoE, USW-16-Lite, and other components, all hardwired by Ethernet.

Connected Audio Devices

Library Size

Description of Issue

Often, after I have a network problem, Roon will lose my NAS.

I just had a network problem and had to reset all my devices (except for the Dream Machine Pro).

Even though I can easily navigate to my NAS in my iMac and open the folder with my music, Roon has lost it. It shows the directory is not available. When I remove the NAS from Storage and try to add it back by specifying the pathname, username, password, etc., Roon still can’t find it. This has happened before, but usually it corrects itself over time.

I’m not sure why Roon is the only thing in my network that can’t see the NAS.

Is there anything I can do to get it to work?

I see that your support document says not to use special characters in a password. What qualifies as a special character, and why was it working until my network problem?


Hi Andrew,
Are you using the IP address for the network share in ROCK, or a logical name?
\\\Music (for example) or \\DISKSTATION\Music (for example)?

Does your NAS have a static or dynamic IP address?
I recommend to reserve static IP for your NAS in your router.

You may try to activate (if did not yet) SMBv3 protocol on you NAS:
Control Panel -> File Services -> SMB/AFP/NFS -> SMB -> Advanced Settings -> Maximum SMB Protocol -> SMB3
as recommended here.

I also activated Bonjour, SSDP and WS-Discovery on my NAS (see “Advanced” tab), but disabled AFP and NFS (“SMB/AFP/NFS” tab)
And disabled IPv6:
Control Panel -> Network -> Network Inteface -> LAN -> Edit -> IPv6 -> IPv6 Setup - Off

Special characters are $, @, %, !, &, # and so on.
I’m sure that it was not an issue before Roon 1.7 (build 521), but since then I use relatively “simple” passwords - lower and upper characters and digits.


Hello @Andrew_Stein,

We’re thankful that you’ve gotten in touch to let us know of this recurring issue. We’d love to help find a solution :nerd_face:

While we got a chance to reply, it looks like @Serge_Tse offered a :sparkles: clear explanation of how to connect your NAS. Thanks @Serge_Tse :pray:

Did you get a chance to try any of the steps?

1 Like

Hi. Thank you both. Unfortunately, despite having tried all those steps, I can’t get Roon to find the NAS. I get the message “There was an Unexpected error: UnderexpectedError.”

I am using the same pathname that was working a couple of days ago. I even tried preceding it with “smb:” I tried name as well as IP address.

And my iMac has no trouble connecting to the NAS. I should note, however, that I am using a ROCK as my core.

Hi @Andrew_Stein

Did you enter the username and password when entering the share information in Roon?

Can you share a screenshot of what you’ve entered into Roon so we can see if it looks correct?

1 Like

Hi. Yes, I have entered the username and password in Roon. I noticed that Synology had assigned a workgroup name and that I couldn’t delete it from within the Synology software, so I even added that workgroup name in Roon, but it didn’t help.

Since I can easily access the NAS over MacOS, isn’t there some way to carry over the connection to Roon? I am running ROCK, I realize, so I can’t simply point Roon to a folder on a hard drive connected to my Mac, but I know I have an available connection to the NAS over my home network. It doesn’t make sense. And it was working until my network problem a couple of days ago. I should add that I still have network problems throughout the house; other devices are having problems over my network. But, again, my iMac can easily access the NAS over the same network.

I could share the screen (when I get home), but is there a way to send it to you privately?

In the meantime, I suppose, couldn’t I connect a backup drive to my iMac and use it temporarily as storage? I realize it isn’t ideal and that the NAS would work better.

Thanks for your help.

Hi @Andrew_Stein, thanks for the details. Yes, you can send the screenshot to me in a Private Message and I can take a look.

What kind of networking issues are you having? It’s possible that the connection between the NAS and ROCK Core is having a problem even when the macOS device is not. Can you describe how each of these devices is connected?

Thank you. When I get home, I will privately send you a screenshot. It’s hard to describe my networking issues. Basically, some Ethernet cables were unplugged from the Dream Machine Pro and the Ubiquity 24-port switch. They were plugged back in but not necessarily in the same ports as before. And then the WLAN stopped working correctly. I have reset all the Ubiquiti devices (including a 16-port Lite switch and four remote access points), except for the Dream Machine Pro (which I have not reset). Now, some of the WLAN works again (and WiFi works), though at least two remote access points remain nonworking. Some network functions don’t work anymore, e.g., can’t print to a wireless printer, Roon not finding NAS, some Google devices won’t phone home, the clock runs backward (kidding). Many devices are hardwired to the Ethernet network, including the NAS. Many connect by WiFi. But my music system is almost completely hardwired.

Another update (as of tonight): Roon finally saw the NAS, and it is scooping up my library again. I don’t know what allowed it to work, but I had just used the BluOS app to select Roon Ready. The app then said, “Roon Ready. Your Player is receiving input from the Roon Ready.” I don’t know whether that selection somehow provisioned the NAS for Roon. But, again, my WLAN is behaving wacky since some Ethernet cables were unplugged and plugged back in in possibly the wrong ports.

I still can’t get my Ubiquiti system to adopt one of the wireless access points (after spending probably ten hours trying), and now Ubiquiti is sending me to tier-2 support.

Anyway, thanks to everyone here for the help. I would like to isolate the factor that made it all work so the next time the network goes sideways I can get Roon back up and running.

Roon has similar problems losing the NAS after events such as blackouts–though not every time.