Strange Audio Issues w/ Ventura [Roon Investigating; Known Apple Issues w/ Ventura System Audio]

I mean, I haven’t had major issues. Just minor little things that are fixed by closing and reopening the app. Those aren’t a big deal, but they happen enough times that you wonder why do all of my other apps just work.

Hopefully this will get resolved, because for now it’s unusable.

Fingers crossed.

@Philip_Gibson Not a peep from the folks at Roon on this topic. What a great company. And, on top of that, we get to pay even more for an app that we can’t use starting in January.

Hi @Daniel_Bykhovsky,

Thank you for your patience and I’m sorry to hear that these audio issues on Ventura have rendered Roon unusable to the point of pausing your subscription. We’ve been unable to reproduce your report internally, but several details in your report suggest the issue may be within the OS system mixer rather than Roon’s RAAT protocol, the Schitt outputs, or Roon database.

Knowing more details of your system’s audio routing would illuminate what might be causing this symtpom. Are you able to supply the tech support team with the following screenshots?

  1. The Audio Midi setup screen on your iMac (Applications → Utilities → Audio Midi Setup). See below for example.

  2. The Sound tab in System Preferences.

Ventura contains an Accessibility update that allows for different configurations of voiceover and background sound. This places a new layer in the System Mixer when engaged, and I’m curious if you’re relying on these features in Ventura. Please also share the following, if possible:

  1. A screenshot of the Audio configuration in Accessibility, also in System Preferences

Additionally, do you experience issues like you’ve described when using any Browser, or is this limited to Chrome?

Once we have additional information, we can try our best to troubleshoot the system settings. With your Roon account deactivated, however, we’re unable to pull automatic diagnostics from your account. If you’re interested, I can flag our @accounts team to discuss options for a free trial we can use during troubleshooting.

@Connor Hi Connor. Well, I guess late is better than never. I reactivated my account.

Here are the 3 requested screenshots. Also, I’ve reactivated my account (I have 11 days left). I really love Roon, so if this issue can be resolved, I’ll gladly continue my subscription.

I’m experiencing the Browser issue with both browsers and the audio completely turns off for the entire Mac until I restart it.


Yes, it would be great if the @accounts team could extend my subscription. If anything, I feel like giving me a free month is only fair considering I haven’t been able to use a service I’m paying for through no fault of my own for coming up on 2 weeks.

Hey @Daniel_Bykhovsky,

I am so glad to hear that you’re up for working with Connor (and our technical team) to get to the bottom of this. Thank you.

Please, check your account page for your extension :relaxed:

@beka That’s great. Thanks very much. I do hope we can get Roon working. This app really has a lot of wonderful features. As my stereo system expands over time, I hope to get even more use out of it.

Now hopefully, @Connor and company can figure out this pesky issue that’s preventing me from using the app at all.

All the best.

1 Like

Hi @Daniel_Bykhovsky,

We’ve reproduced the issue internally and have escalated to QA/development. I’ll report back as soon as I have a fruitful next step. In the meantime, unfortunately, the only relief I’ve found is by taking one of the following steps:

  1. Restarting the Mac
  2. Using terminal to reset Core Audio on the Mac. Go to Applications → Utilities → Terminal . Type in “sudo killall coreaudiod” and press Enter . This should reset your Core Audio daemon.

I’ll report back shortly.

@Connor That’s great(?)! Look forward to getting this problem resolved. Thanks for your efforts.

Hi @Connor. So this latest update seems to be a response to a different issue. I’m still having the same issues.

Is there a timeline for the solution to my bizarre problem? Maybe a rough estimate of when this could possibly be resolved?

Also, I just wanted to attach a screenshot of what happens to Youtube (and I assume other sites that play any kind of visual/audio media).

Finally, not sure if this helps, but when I close and reopen Roon after this issue starts, Roon can’t locate any of my audio devices.

Basically, restarting my Mac and not using Roon is the only option, at the moment.

for Apple Studio Display and probably also iMac users: try to disable “exclusive mode” in the device settings: Roon → Settings → Audio

if I don’t switch it off, I have to to pause music playing in Roon before calling or receiving a MS Teams or Facetime-call… else I have similar troubles

Thanks, but that’s not the issue.

Additionally, in my case, I have an external dac that I use for music. So, when everything is working as it should, Roon has exclusivity with my external dac and anything else will produce sounds through my iMac speakers.

Update: I was researching my issue on Google and noticed that there was a thread (Possible MacOS Problem with Coreaudio) that mentioned a similar problem during the beta phase Mac OS Ventura.

So, it seems that Mac OS Ventura 13.0 was the problem.

This gave me the idea to try to the current public beta of Ventura 13.1.

In short, the problem seems to have gone away…sort of.

I can now go back between Youtube and Roon, but Roon takes some time to get going. First it doesn’t recognize any of the audio devices, but within maybe 10 seconds, everything stabilizes and things seem to be fine. The same applies to Youtube. It takes a moment for things to get going. Not great, but workable.

Hopefully, the kinks will be ironed out by the time 13.1 is officially released in about 2 weeks.

Fingers crossed.

Hi @Daniel_Bykhovsky,

We continue to reproduce this inconsistently internally, and we’ve submitted a Radar report to Apple to address coreaudio issues with the initial release of Ventura.

As you’ve mentioned, this issue appears to be unfortunately widespread, and not limited to Roon’s interaction with the system output. That said, Roon’s designated this as an Apple bug internally, we’ll continue to investigate if there is a potential workaround or improvement we can make to stabilize Roon’s all-in-one performance on Ventuera.

In the meantime, I recommend the terminal Core Audio reset as an alternative to restarting the computer or relaunching Roon:

Using terminal to reset Core Audio on the Mac. Go to Applications → Utilities → Terminal . Type in “sudo killall coreaudiod” and press Enter . This should reset your Core Audio daemon.

We’ll post an update here as we have additional news. Thank you for your patience.

1 Like

Glad to see this is a know issue. My iFi Zen DAC v2 is only occasionally recognized by Roon in Ventura. Unfortunately, restarting Core Audio does not solve the issue. This currently renders Roon usable. Hopefully a forthcoming MacOS 13.1 update rectifies the issue. If you’d like to run any further testing, please let me know. Cheers!

MacOS 13.1 has been released. Let’s see if we continue to experience the same issues.

By no means has my testing been exhaustive, however, since upgrading to MacOS13.1 I have not experienced this previously frequent issue.


Yes, it seems that the problem has gone away with Ventura 13.1.

1 Like

13.1 has not resolved this for me. My Schiit DAC is often not recognized by my 2021 16" MBP. Often I’ll look in Audio Midi Settings to see what’s going on and often, but not always, that application will hang and I’ll have to force quit it. This is a recent issue for me and, though I can’t say for sure, seems to correspond with my upgrade to Ventura. The workaround that @connor suggested does typically work for me. Patiently awaiting any news here!

I too occasionally need to “sudo killall coreaudiod” in order to see my iFi device.

I do appreciate the reminder. I’ve tried it and it worked sometimes, not others, and has stopped working at all. Nothing will make my Schiit dac visible.

Tried different cables, different ports, no luck.

Audioquest Dragonfly black via USB C adapter works fine.

Tried going through a powered USB hub that I have some external drives plugged into. That worked, but I got an error message that a USB accessory was drawing too much power and would be shut down. The dac worked at that point, and I don’t think the total power draw of 2 drives and a dac exceeded the power available from the USB port. However, I didn’t want to fry the port, so I dropped that solution.

I tried a separate powered USB hub, didn’t work.

My answer has been a WiiM Pro streamer. Coax out of the streamer into the dac, works like a charm. Maybe a future mac OS update will fix it one way or another, but that’s my story!

1 Like