Strange behaviour on ROCK NUC5i3RYH 8GB / 240GB SSD OS / 2TB SSD Internal Storage / 2TB External HDD

I do appreciate my machine is not in spec but hoped you might have some insights

HP Elite 8300 SFF PC Intel Core i5-3470 3.2GHz 12Gb
Operating System

Version 1.0 (build 227) stable

Running 21 days, 12 hours, 9 minutes, 9 seconds.

Roon Server Software

Version 1.7 (build 610) stable

Running 1 hour, 11 minutes, 12 seconds.

Mock wired to Mikrotik router - control and end-point on wifi

Sonos One

Recently when jumping to a new track or album whilst another is playing, either on local files or Tidal, I often get one of the following; Play Now pressed - Track 1 skipped completely, playback starts on Track 2.
Track Play Icon pressed - track plays for 2 seconds then skips to next. or
Track Play Icon pressed - track plays for 2 seconds then audio of next track starts playing but display shows original selection. or
Play Now or Track Play Icon pressed - brief burst of white noise then next track plays - seems to only be on local files

Apart from white noise - this isn’t completely new behaviour but has become more common of late

Files stored on internal SSD and external USB -

Sorry for the delay due to the holiday weekend, @MrDenis.

Does this happen for all endpoints? If you play to System Output of a remote device do you experience the same issues?

Are there any specific types of tracks (i.e. high res tracks only) that seem to cause this?

1 Like

Hi @dylan - hope you had a good holiday weekend

There’s been a noticeable improvement after a reinstall. I had tried restarting server software numerous times but an OS reinstall has now got rid of most of the issues.

The one outstanding is Tidal tracks skipping - though this is less frequent than before and having read through some of the other posts this might be down to my network environment? I can currently see 26 SSIDs other than mine!

A congested WiFi are sounds a plausible reason for the beahviour you described. Can you try and wire your equipment momentarily? That would give you the clear answer.

It’s on my list to wire the speaker in permanently so hope that does the trick - doesn’t seem to happen to other wireless end-points but I don’t use those as much

For now the re-install/power-cycle has dealt with the worst issues

1 Like

Hi @MrDenis,

Using a wired connection is definitely preferred, so I’d recommend that if possible. I’d also be curious to know if this happens if you switched to a different Core machine temporarily — Does this happen in a different configuration as well?

So I’ve spent a few hundred pounds upgrading from Mock to ROCK - NUC5i3RYH - with wired connection to Sonos - BUT I’m still experiencing skips - Play Now on an album might start with a pause then track 2 plays - and just now I played a track, it played, I clicked on blue tag and playback stopped
Very frustrated now that I’ve invested in the recommended hardware without any improvement

Hello @MrDenis, and my apologies for the frustration here. Do you experience these skips when playing to system output of your remote? Can you please elaborate on your network setup?

Hi @nuwriy - these skips happen when playing to Sonos One end-point with both wired (current) and wireless connection controlled over 5Ghz wireless (also when wired) from an iMac 2011 High Sierra situated less than 2m from router.

The Sonos One and ROCK NUC are both hardwired to a Mikrotik hAp ac2 router, there is another Sonos end-point wirelessly connected to the first and a wireless Chromecast audio - I don’t notice skips on these but they are less used and are usually background players.

Skips happen on Flac, Alac, Mp3 & Tidal - it happens about one in 15 attempts to Play Now - for testing everything in chain is now cabled but skips still occuring

Do you have a spare basic un-managed switch like the Netgear GS105NA? I’ve found that sometime the switch part of these routers are not the best.

If you have an extra switch, plug the switch to the Mik., and then plug everything else into the switch. this will bypass the router when devices are communicating internally.

I won’t be able to try that for a few days - though I’m puzzled that behaviour remains whether on wired or wireless

I had an incident earlier where it took 4 attempts hitting Play Now for track 1 to play of a particular album - however once it played the error wouldn’t repeat

It feels to me like a failure to connect media to the Sonos One - the brief white noise makes me think this and as I say other end-points don’t seem to be affected

This is part of the log where track 01 Kitty Bey was skipped and track 02 Ether was played

09/19 16:09:03 Trace: [Kitchen] [LowQuality, 24/44 MP3 => 16/44] [LOADING @ 0:00] Kitty Bey - Byron Morris / Unity / Byron Morris & Unity
09/19 16:09:03 Info: [Kitchen] [zoneplayer] Playing: /roon/sys/storage/mounts/InternalStorage/DroboFlac/Byron Morris and Unity - Blow Thru Your Mind (1974) [FLAC]/01 Kitty Bey.flac
09/19 16:09:03 Trace: [Kitchen] [zoneplayer/sonos] endstream, zp state: Disconnected
09/19 16:09:03 Info: [Kitchen] [zoneplayer] Queueing: /roon/sys/storage/mounts/InternalStorage/DroboFlac/Byron Morris and Unity - Blow Thru Your Mind (1974) [FLAC]/02 Ether.flac
09/19 16:09:03 Info: [Kitchen] [zoneplayer] Open Result (Playing):Result[Status=Success]
09/19 16:09:03 Trace: [Kitchen] [zoneplayer/sonos] endstream, zp state: Disconnected

On this occasion, as on others, there was no indication on Roon Controller that Track 2 was playing and the progress bar remained frozen at beginning of track 1

my Sonos details

Sonos One: Kitchen
Serial Number: 78-28-CA-04-3C-2C:4
Sonos OS: S2
Version: 12.0.5 (build 58180080)
Hardware Version: 1.21.1.8-2.1
Series ID: A100
IP Address: 192.168.0.27
WM: 0

Hi @dylan @nuwriy - just wondering if there were any ideas before I invest in more new hardware?

Hi - anyone home?

I’ve had an issue for over 3 weeks now

I’ve invested significantly to bring my hardware up to supported specifications

Despite posting updates on the issue and excerpts from logs I’ve had no response in 5 days

Do I still have a support agreement in place - how long does ‘lifetime’ support last?

1 Like

Hello @MrDenis, and my apologies for the delayed response. It was my error that caused this thread to be overlooked. I spoke to the team yesterday about this issue and we wanted to clarify an item. Do you see this when playing to the one Sonos zone only or to both Sonos zones? Also, thank you for the log traces!

I was getting error Roon lost control occasionaly on other Sonos - however that was usually midway through a track not at the start and was at edge of wi-fi

I’ve now bought an extra switch and EVERYTHING is hard-wired - I’m STILL getting skips when using my iMac as control and Sonos One as end point

This seems to be a more regular issue since the update

What do I do next?

Update: Listening to Roon Radio on Sonos One this morning - had a track skip to next partway through - I did a manual Cue Previous and track played back uninterrupted

How do I work out where the problem lies?

Hello @MrDenis, have you tried using Airplay to connect to your Sonos instead to see if that presents any change? I had our team enable additional logging for your account to get more detailed diagnostics. If you could please try Airplay and in the event the issue persists, please reply here with a timestamp (your local time) and we’ll enable diagnostics for your account to collect the report.

Lastly, could you please send me a screenshot of your network settings in the WebUI?

Hi Nuwriy - the change to Airplay seems to have worked - thank you

I reverted back to Sonos Streaming and errors occurred again soon after - do you receive logs automatically or do you need me to send them so you can see the errors?

09.12 Leo’s Sunship exhibited skipping over wi-fi
09.18 Casablanca Records Story skipping over wired connection