Strange problem: Roon won’t allow me to add a CD to my library [Resolved, hidden album]

This is peculiar. I noticed the the most recent cd from Cecile Mclorin Salvant “Dreams & Daggers” simply won’t be saved to my library. I’ve tried multiple times. It’s not like I don’t know how to add cds to my libary - I’ve added hundreds.

I just can’t figure this out. Shame coz it’s a wonderful piece of music.

Two suggestions:

  1. Go to Settings>Library>Skipped Files to see if the tracks you are missing are listed there
  2. Check these restrictions on what Roon can import


as above, but also has it been misidentified as something else? Have you tried searching for all parts of the title and artist name? I presume it is in the same location and folder structure as all your other library storage? Where did the metadata come from? Have you tried deleting it all and letting Roon reidentify the album? Is the character (accent?) over the ‘e’ in Cecile causing an issue? Roon used to have issues with accented characters, and they were due to be fixed in the next release after 1.3. Whether they were or not is the question.

Create a new watched folder and put only this cd in it, allow Roon to add it then use focus to look at only the folder you put the cd in, this is done via storage locations, then irrespective of what it was added as you will see it.

That’s unlikely to be the problem. From my library:

Thanks for everyone’s replies and advice - much appreciated. I finally “recovered” the CD by simply unhiding it. I guess I must have somehow hidden it in the past, without realizing. What I find confusing is that it was necessary to unhide it - and my library wouldn’t accept a new addition. Anyway, pleased to say that it was another day of discovery with Roon.

1 Like