Strange Problem with Track placement in Roon

I checked the Meta Data a couple times and from all I can tell its correct ,But for somereason
The second track on The Lp is repeated as track 5 ,and The real Track 5 appears under it indented with
a small circle where the Track number is ,I tried fixing it with Roons editing tools ,but only if I remove
the track from The Lp will the track order go back to the correct order,of course without that track

Hey @Peter_Neski – Thanks for reporting and sharing your feedback.

To further look into this issue there are a few things I need from you:

  1. Can you share a screenshot of your folder structure where you are storing the media?

  2. Can you please provide a brief description of your current setup using this link as a guide.

  3. Have you tried re-importing since you’ve noticed this issue?

    • Move the content out of your watch folder to a safe location where it will not be lost or deleted. Because I always error on the side of caution, you may also consider making a copy of the media, just to be safe.

    • Once the content has been removed from the watch folder please use the “library clean up” feature so Roon treats the media as a “fresh” import" (path: “settings” > “library” > “Library maintenance” > “clean up library”).

    • Lastly, please re-import the media into Roon and verify what the experience is like.

Well I solved this problem and fixed it and when it happed again ,I did the same thing to another lp that
had the same time happened ,and the problem seem to happen when I use Identify album feature
Most times I just use my meta data for track title and media number and track #,but sometimes this doesn’t
work ,so I found by using “None of These look right” it fixed the problem of tracks without numbers

Lately I been having trouble because My Files are o a hard drive which is plugged into my Router
I do a lot of adding files,and a lot of times I have to reboot the router to get it to copy
Not sure when I can afford a separate computer or Innus device since the only DAC I have is my Bluesound

Hi @Peter_Neski — Thank you for your patience here, I greatly appreciate it!

I discussed the behavior you’re observing with a member of our technical team. The file name for “Call of the Blues” could be contributing to this behavior and causing Roon to interpret the file in a different way than expected.

Can you try editing the file name for “The Call Of The Blues” so that it matches the naming convention of the other tracks (ie. 5- The Call Of The Blues) and then try re-importing the album? Make sure that you have a copy of your files somewhere you can access them before choosing to delete them in Roon so that you do not lose these files.

Please note that, after you remove the album, and before re-importing, you’ll want to use the Clean Up Library option in Settings > Library to remove and information on the album that Roon may be storeing in the database.


Thanks ,I fixed the track and it worked

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.