Streaming Roon to AppleTV while keeping it secure!

This is more of a tech tip rather than asking for support.

I have searched the forum and most folks who had issues enabling Roon on Apple TV via Airplay had issues due to constant prompts for a 4 digit passcode.

While yes, disabling all requirements bypasses the whole thing, its insecure as other items can freely airplay (even if restricted to same wifi).

Instead, if you want to keep the best of both, go to

Settings > AirPlay and HomeKit > Allow Access and choose the following:

  • Allow Access > Anyone on the Same Network
  • Require Password > ON
  • Password > whatever you set it to

Seems like Roon struggles with randomized 4 digit Pins and password (number or phrase works solid instead)

1 Like

Cheers, drinks on me. :beers: That saved me a lot of work.
Thank you

You’re very welcome :slight_smile: