Streaming to Sonos loses synchronisation

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro version 1903 OS build 18362.418 / CPU: Core i7-6700HQ, 16GB RAM

Roon version 1.6 (build 416) stable (64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi network, Asus RT66AC router / access point. Broadband internet up to 300mbit.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos Play:5 gen 1, connected over WiFi.

Version: 10.4 (build 521369030)
Hardware Version:
Series ID: B100

Description Of Issue

When I select the Sonos 5 system as a zone to play back to, and start playing an album streaming from Qobuz, I notice that after the first song the “now playing” on both my Roon Remote app on iOS and on the Roon Core, and on the Roon Display, stops tracking the progress in the track. It always stays at 0 seconds.
Next I realised that at some point, a song from the album will be played twice and at this point, the album name that is displayed will be out of sync with the actual playing song as well.

I’ve clicked the track to play in the playlist to jump to it, but that didn’t make the problem go away. The progress in the song was not tracked, and the “now playing” displays got out of sync with the song actually playing on the Sonos. Play / pause controls still worked, as did the skip button etc.

I have restarted the Roon Core software but the problem came back after a single track was played.

The Sonos app meanwhile indicated that the Sonos speaker was playing song “Roon.flac” so it was definitely playing from Roon.

I have configured Qobuz and Tidal services. I have a few songs locally on my computer but not many, and not this album.
The album I was playing was “Nest” from the Dutch band “Nits”; I was playing it from Qobuz but it’s also available on Tidal.
Several of the tracks on the album are available in multiple locations, and it’s in “my library” on both Qobuz and Tidal.
This makes me wonder if that is what causes songs to be played twice in a row, and the “now playing” displays to go out of sync, however I am now streaming the very same album directly from Roon Core into my USB-Dac connected to the same computer, from Qobuz again, and I have none of the above problems. Everything behaves as expected.
The problem therefore must be related to the playback via Sonos.

Hi @Tim_van_der_Leeuw,

Thanks for the report here. I have gone ahead and activated diagnostics mode for your account and what this action does is automatically upload a set of logs to our servers for analysis.

Once they arrive, I’ll take a look to see if there are any clues as to what occurred when you were playing that album.

Can I also ask that you let me know the exact local time, date and track when you next notice this behavior? Having the timestamp alongside the track will help us track any patterns towards this behavior.


Hi Noris & support team,

Thank you, I will be experimenting with this today and I will inform you when next I see this problem (either with the same album or a different album).

Kind regards,


Hi Noris & Support team,

It is now 12:08 local Amsterdam time and about a minute ago I noticed again the same behaviour.

Track playing: “Such a Shame”, Talk-Talk.

The track progress stopped tracking at 0:34 in the track of 5:35 minutes long.

While typing it is now 12:09 Amsterdam time, a new track has started playing, the now-playing display doesn’t show me which track this is.
Counting back the synch must have been lost around 12:04.

  • I started streaming the album “Spirit of Eden” from Talk Talk, via Qobuz.
  • I was streaming from the Roon Core to Sonos, now combining 2 Sonos devices (same Play:5, and a Sonos Connect which has just arrived). The Sonos devices are separate zones grouped together.
  • After the album was finished, and tracking was synchronized just fine, Roon Radio started playing more tracks.
  • It was during the second track streamed via Roon Radio, “Such a Shame” from Talk Talk, presumably also streamed from Qobuz, that the synchronization got lost.

I hope this information helps.

Kind regards,

–Tim van der Leeuw

In addition, now, 12:16, I see on the “Now Playing” display that the track “Heatwave [Audiophile version]” from The Blue Nile is supposed to be playing. Progress is not being tracked.
However the song previously playing, was the same song, but then the display was still showing “Such a Shame”.
So now I also have the previously reported problem of same track playing twice and display not showing me the correct track-name.

The same problem is currently happening again, after having restarted the Roon Core. Local Amsterdam time 18:22, playing the album “Without Judgement” from Jah Wobble’s Invaders of the Heart, streaming from Tidal. I noticed it while the track “Burger Bar” was playing – suddenly the track stopped. I went to the Roon app, saw that it still showed the previous track, “Coypu”. After a few seconds the track “Burger Bar” started playing again. No progress of the track shown.

Hi @Tim_van_der_Leeuw,

Thank you for letting me know those timestamps. Now that I have this information, I have gone ahead and activated diagnostics mode for your account and what this action does is automatically upload a set of logs to our servers for analysis. I will take a look to see if there are any additional clues located in the diagnostics once they have been delivered.

1 Like

14:11 27/10/2019 (Wintertime Amsterdam, so UTC+1) I’m streaming from local albums and I was about to write that above described symptoms do not happen but alas, I upon coming back to Roon after having been out of the room for a while I see playing “Stolen Land” from Bruce Cockburn from a local drive play-counter stuck at 1:46, not progressing anymore. I think the songs actually playing was “Strange Waters”, the next song from the same album.

So also with local files, same problem happens, playing to the Sonos system, the “now playing” tracker stops accurately tracking progress in songs, stops tracking songs.

It must have been around 14:00 - 14:02 Amsterdam time / 13:00 13:02 UTC time that the loss of synchronization must have happened based on the time I looked at Roon again, and the length of both songs.

PS: One more thing that I noticed is that when I suspend the laptop and wake it up again, the synchronization of what’s playing is temporarily back.

Also, it seems to happens much quicker when playing from a streaming service than when playing local files.
This makes me wonder if it’s some sort of clock-synchronization issue at heart of the problem?

Hi @Tim_van_der_Leeuw,

Thank you for letting me know those additional timestamps, I can confirm that diagnostics have reached out servers. I have placed a request for the technical team to review these diagnostics and provide some feedback regarding them, I will be sure to let you know once I have any further information to share. Thanks in advance for your patience here!

1 Like

Hi @Tim_van_der_Leeuw,

I appreciate your patience while I had a chance to discuss this behavior further with the technical team. I had a meeting with the technical team recently where we discussed the diagnostics gathered and we can see this issue, but it is not clear what exactly is causing it.

The best way that we can address issues is by getting them reproducible in a lab environment. Are there any patterns that you have noticed that consistently reproduce this behavior?

For example, does playign the same tracks you mentioned earlier get you into this state? Are you switching between Roon and the native Sonos app? Do you play content that is different sample rate right before it occurs? Do you ungroup your zones and regroup and only after this issue starts to occur?

If you can provide any additional observations it would greatly help towards debugging this issue, otherwise we will have to wait for QA to try and reproduce in the lab, and this might not be entirely successful if the issue is dependent on a certain action or external factors.


I’m not sure what is specific about my setup and I haven’t played over Sonos for a while but what I can say is:

  • I’ve noticed it both when playing to a single Sonos speaker, and to both Sonos devices grouped together in a zone
  • Since grouping them together in a zone, I haven’t ungrouped them so the grouping/ungrouping is not a factor
  • I see this with any content I play, it’s not limited to any tracks
  • The issue happens faster when streaming via either Tidal or Qobuz – sometimes within a few tracks already of an album
  • The issue also happens when streaming from files stored on the same Windows machine as the Roon Core is installed on, but it takes much longer to occur then
  • When I hibernate the Windows computer and wake it up again, the issue temporarily goes away
  • So far until now, all devices have been connected via WiFi. The laptop via 5GHz WiFi, the Sonos devices only have 2.5GHz WiFi I believe.
  • It doesn’t matter if I’m using the laptop for something else or not.

I have connected a LAN cable to the Sonos yesterday but not yet tried since then.
There’s no LAN attached to the laptop running Roon; it’s too far from any switch or router normally for this to be feasible.

When I have more findings I will post them to this thread.

My own preliminary conclusion so far is that it might be related to network-congestion or packetloss on the WiFi in some way, or clock-skew that is triggered by network related issues.
My reason for this that the issue is much less likely to occur, when the source I’m streaming is from local disk than when streaming a source from the network.

Thanks for your time and investigations so far.

1 Like

Hi @Tim_van_der_Leeuw,

Thanks for summarizing your observations so far, I have noted these in the internal ticket regarding this issue and will pass them on to QA.

Once we have scheduled some time to take a look at the gear we have in-house and try to reproduce this behavior, I’m hopeful that your observations will help narrow the issue down further.

If you make any new observations in the meantime please do feel free to let me know. I will be sure to let you know after I have discussed with the hardware team and have taken we schedule some testing time. Thanks!

1 Like

Hello @Tim_van_der_Leeuw,

I would also be interested to learn if the Sonos Connect exhibits the same behavior. Thanks again for all of the information you have provided, we’re investigating internally.


Hi @john,

I was testing this with the Sonos Connect. I’m now for the first time testing with the Sonos Connect hooked up via ethernet instead of WiFi; I’ll let you know the results later in the day.


At 14:52 local Amsterdam time I can see the problem again.
The last song played restarts (“Flowers and Beads” by Iron Butterfly).
The play-time tracker is not tracking, stuck as 0:00 seconds.
The previous song of the album, “Most Anything You Want”, is played only for 90% – So already there the problem really started, only I hadn’t noticed yet. The time would have been around 14:48 ~14:49 …

And now, as the clock was just about to turn 14:55, the next song starts playing (“My Mirage”) but according to the “Now Playing” tracker, it is still “Flower and Beads” that is playing.

The ethernet cable has not made any difference, in other words.

NB: I’m streaming to just the Sonos Connect. The Sonos Play:5 is not playing at the moment.

Hi @Tim_van_der_Leeuw,

Thank you for checking the Sonos Connect and for confirming that the same issue occurs there.

I am seeing multiple Roon Cores listed under your account, can you please confirm which Roon Core you used to perform the test on the Sonos Connect?

Since you have switched to the different Core, is the behavior the same on the new PC as well?


Multiple Roon cores?? No, I use only one, the Windows machine stated in the original post.

I did however try to install Roon as a Core on an Apple MacBook, but since I got the warning that this was not allowed without demoting the existing Core to be endpoint, or charge extra to my account, I did not actually do this. The MacBook is running only as endpoint. (I was not aware of this limitation when installing the Roon App on the MacBook).

My account should have only one single Roon Core.

There’s a Raspberry Pi, which is running Roon Bridge, and several mobile devices with Roon App installed for different members of the family.

Hi @Tim_van_der_Leeuw,

Thank you for clarifying that the Windows 10 was the only active Core, I can confirm that logs from this Core have been received and I have located the relevant traces.

Yes, this is expected behavior, you are limited to running just one Roon Core at a time per subscription.

Since you do have another PC that can host the Roon Core, I would suggest verifying if the behavior is the same on that one as well, can I please request that you check?

To switch the Core, I would suggest creating a Roon Database Backup of the PC and then from the Macbook, you can go ahead and un-authorize the PC core and authorize the Macbook as the Core.

You can switch between Cores as often as you like, and knowing if this same behavior occurs on your MacBook for the Play5 or Sonos Connect would provide a useful data point.

1 Like

I will try, and get back to you when I have some results.

1 Like