Struggling To Connect QNAP to Nucleus Plus

Hi everyone glad to be here
If I had hair I would have none left now, just recently purchased the Nucleus Plus

set up
Nucleus Plus (Core) Huawei MediaPad M5 (Remote) also Ipad(Remote)

QNAP TS-253A Firmware 4.3.6 4GB Ram Intel Celeron CPU N3160 @1.60GHZ (Storage)

Chord TT Dac usb to Nucleus
Audiolab Preamp
4 x Audiolab 8300mb mono amps
Monitor Audio Gold 300 speakers

The Nucleus set up fine and streams Tidal no issues , also I have a external WD Essentials external hard drive that connects usb to Nucleus and streams no issues

Problem is Streaming from Qnap to Nucleus keep getting various errors when add network share

have tried smb:// also smb://SimonNASFLAC/multimedia/Flac
also \\multimedia\Flac also \SimonNASFLAC\multimedia\Flac

but have just put Roon on PC Windows 10 as the core and typed in \SimonNASFLAC\multimedia\Flac and it works fine but dont want to use PC as core thats why i bought the Plus

When i look at the Qnap settings in microsoft networking /advanced options/ highest smb version is SMB 3
NFS /FTP is ticked

permission multimedia everyone Read Only Admin Read Write

have read the forum and tried all the suggestions and am still lost

please help someone

Simon blake

Is the folder you are sharing an actual shared folder. I did not put my music in the multimedia folder so had to manually share the folder we used within QNAP. Not sure if the multimedia folder is shared?

have attached screen shots

sorry replied via mail didnt realise here

from my limited knowledge of this multimedia is a shared folder

Hi @Simon_Blake,

Is there any difference in how the Windows device is connected to the network vs. the Nucleus?

Can you confirm you’re entering the proper username and password for the share when entering it on the Nucleus?

thank you for your post
Before i bought the Nucleus the Qnap was connected to router via switch and then a pioneer n30 streamer all by ethernet
Same Huawei tablet running Qnap app Music Station , all worked fine , ok didnt have the software that the Nucleus has but i could stream from the Qnap to the N30 with no issues
The passwords were the same as they are now and no issues
Have tried every option,

Have tried in my browser on windows it works fine opens login in screen to Qnap
Tried same on Huawei and Ipad doesnt find the log in so is the issue there Iam confused

Help !!!

Not sure if the command is case sensitive? I see in your command you have ‘multimedia’ but in your screenshots it is shown as ‘Multimedia’, try ensuring your command syntax is exactly matching.

Hi @Simon_Blake,

Does the password contain any special characters? If so, if you change it to something that doesn’t contain special characters is there any change when using smb://SimonNASFLAC/multimedia/Flac or smb://


Thank you for the contact have tried both Multimedia and multimedia

Dylan once again thank you , the password contains no special characters but have change it

when i enter smb:// i now get could not connect to share host not found

but when i enter smb://SimonNASFLAC/Multimedia/Flac i now get invalid network path specified


The reason that the Nucleus+ cannot find your NAS when using the domainname is because the domainname is not being pushed by your router. So let’s focus on using ipadress instead.

I don’t really see the need to address the smb server. Could you try \\\Multimedia\Flac (or flac, when not written with a capital “f” and also notice the backslash “\” instead of the forwardslash “/“) enter your credentials and try again.


Thank you
Have tried what you suggest typed exactly as you suggested and I get could not connect to share unauthorized


You got an error message regarding authorization?

Do you use the admin account credentials when trying to connect to the NAS within Roon?

This obviously means that something is not setup correctly on the Qnap side. I use a Synology NAS so I am not familiar how to setup the correct privileges on a Qnap NAS. Maybe a Qnap experienced user can shine some light on how that’s done correctly?

Hi @Simon_Blake,

Can you try connecting once more using both the NAS name and the IP address and make a note of the time that you try each? Respond here with that time and we will enable diagnsotics so the team can take a closer look.

I have used a QNAP running Roon, not with a seperate Roon Core, but it would appear Simon has done all the right stuff. I agree that connecting via IP would be the answer rather than domain name. Might be worth turning all the network devices off and your Router (assuming it is dynamic IP) and rebooting it. Then reboot all your devices and have a look at the router admin to make sure they are all connected and with what IP address? Worth a go I think.

There is no need to use credentials at all. @Simon_Blake has enabled Guest - Full access.
There’s no need for that, and Roon will only need Read rights.
But you did say that neither of your tablets could connect? Can you verify that their ipadresses are in the same range as your Windows pC and the QNAP?

And one more thing, in the Storage section of your Roon Core try and add “\\\Multimedia”
As a network place… Then you select your desired folders in the next step?

Mikael thank you for your time
i have tried no credentials it comes up with could not connect to share unauthorized
The tablets both can connect to the IP Address no problem

Russ thank you for your time

I turned everything off and switched back on they are all connected but the Nas now has a new IP address

Dylan 17.56 Nas name Could not connect to share Unauthorized
17.58 Ip same as above

Ip adress has changed
also created a new share folder music with guest rights etc and that doesnt work either


@Simon_Blake I think it would be a wise idea to give your audio equipment fixed IP addresses (NAS and Nucleus+). You should do so on your device that runs the DHCP server, most likely your router. Otherwise (after we fixed the issue) you will be in the same dilemma after you reboot your router since you can’t use the domainname of the NAS.

I am still convinced that the reason for this particular error are misconfigured permissions regarding your flac folder on your QNAP NAS. I am a bit disappointed that no QNAP experienced user is able to help you out.

Maybe contact QNAP for some support?

It’s a long shot but you could try to create a new user on your NAS (name it Roon for example) and give it read and write access to the Flac folder. Then try to connect your Nucleus with the NAS using the new user account credentials and the matching ip adres (\\192.168.1.XX\Multimedia\Flac, where the XX represent the current IP-adres of the NAS).

Simon you have a private message.

Hi @Simon_Blake,

Thanks! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

to everybody who has contributed to this topic , I would like to apologise for the reason for the issue was entirely mine

I was Entering admin for a username when it should have been Admin “capital A”

Ratbert/Dylan/Anthro/Mikael/Russ my deepest apologies but thank you for your patience and input its greatly appreciated

Lesson learnt

Simon it happens to us all, glad you were able to sort it out and more importantly got your music back…I’m always a little distraught without my music.