Stuck adding tunes to library [Solved]

I have a rather large iTunes library (about 40,000 songs) which is stored on a USB hard drive attached to my Mac mini.

Roon has been adding “Adding Music to Library” for about two days now. Is it normal for it to take this long?

Nope. It should of been done in about a ½ hour or so.

There are some bug fixes in the next release that may improve this issue. If you can identify which files Roon is getting stuck on, it can sometimes help to convert them into another format and then back to the original using an up to date conversion utility. That can get rid of difficulties arising from any legacy differences in file format definitions.

We’ll leave a notification for @vova here so he can investigate further.

Hey @Trevor_Nathan can you please press on spinning wheel in the top right corner of the app:

And make a screenshot of the appeared popup:

Hello @andybob

I am seeing the same exact issue with my Roon install - it is claiming that 0 of 8 tracks, 8 added, 0 identified. This has been showing for the past couple of days.

This message appeared after I added the brand new Peter Gabriel PG 4 flac files.

Hey @louawalters, are in this state now ? If yes, ping me. I’d like to gather your logs and troubleshoot.

It is
But Imy not at home. Can you let me know how to get logs and when I get home, etc I’ll get them you you.


A reboot of the roon server fixed it…

I get this as well, often when the tracks are never going to be identified.

Sorry forgot to reply to this… I rebooted the server and it was fine second time around