Stuck at 1.8 with Apple M1 Mini?

I was wondering why my Mac Mini M1 says I have the latest version installed? Isn’t 2.0 the latest? How can I get 2.0 installed? I am running Monterey 12.6 on the M1 which is their latest software

Unless I am reading this link incorrectly, I can no longer use Roon, other than version 1.8, on a Mac Mini M1? It only runs on Catalina and not Monterey?? Wow, how disappointing is that! I can’t install Catalina on my M1 Mini

Go to the download Links for Roon Core 2.0 and download the version you need and install it.

It says Catalina or later….

1. Unsupported Core device

Compared to Roon 1.8, the minimum recommended requirements for your Roon Core have changed. Roon 2.0 requires macOS 10.15 (Catalina) or later, Windows 10 or later, any version of RoonOS, or any recent Linux release (back to approximately 2014).

If your Core or desktop remote(s) do not meet this minimum specification, they will be unable to run Roon 2.0. If you wish to run Roon 2.0 or later, you will need to update any computers that are below the minimum specification, prior to installing Roon 2.0.

You are.


Thanks for the help. Will Roon eventually say there is an update available for my core like it has in the past?

Where is 2.0 download for OS? This link for MAC OS downloads a file called Roon.DMG . Is this 2.0?

You seem to be on 1.8 legacy. You won’t be offered an update to 2.0 automatically.

To get you on 2.0 (if that is what you want), you can download it and just install it over the existing version. I can’t verify the link from here, but it would be a Roon.DMG file.

Thanks all.

2.0 is up and running!