Stuck at white loading screen

I have the same issue on my Mac OS X 10.14.6
Everything was working fine few days ago, but yesterday when I started roon I first got an error about Tidal signin, then i restarted, there was no tidal or quobuz connection, I restarted again and now it stuck forever in this white loading screen. Even tried to reinstall from the website.
Please help - it’s not working at all!!!

Sorry for the trouble here, @Andrii_Parubets!

Can you give us some details about your setup?

Please also use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).


My setup is just normal Mac Book Pro 15" running roon :slight_smile:
I found an error in log files, and it’s connected to Tidal sync: here is the critical error log file:

07/14 18:11:23 Critical: scx: System.NullReferenceException: Object reference not set to an instance of an object
  at Sooloos.Broker.Tidal.Module._UpdateLocation () [0x0019d] in <b714fbd0ecef49f1b71488885d7de85e>:0 
  at Sooloos.Broker.Tidal.Module._TransitionStatus (Sooloos.Broker.Tidal.Module+_LoginStatus new_status, Sooloos.Tidal.LoginResult login_res) [0x0016e] in <b714fbd0ecef49f1b71488885d7de85e>:0 
  at Sooloos.Broker.Tidal.Module.Init (Sooloos.Broker.Database db) [0x0015c] in <b714fbd0ecef49f1b71488885d7de85e>:0 
  at Sooloos.Broker.State._InitMediaThreadAsync () [0x0007a] in <b714fbd0ecef49f1b71488885d7de85e>:0 
  at Sooloos.SynchronizationContextThread+<>c__DisplayClass45_0.<Post>b__0 (System.Object _) [0x00000] in <3e1335ca9e6b4a298804e0706d86f9c5>:0 
  at Sooloos.SynchronizationContextThread._Dispatch (Sooloos.SynchronizationContextThread+SendOrPostWrapper& ret) [0x00012] in <3e1335ca9e6b4a298804e0706d86f9c5>:0 

fixed by deleting tidal_account file!

Hello Andrii
Did you just delete Tidal from your Mac to fix this? Since I can’t get into my Roon account past th while blank screen I was wondering how you deleted Tidal from there.

Hey Brian,

if you can see in the log files that you have critical error connected to Tidal login, you need to go to Library/Roon/Database/Registry/Core/ and delete file tidal_account
Then you can start roon again, and just re-login into Tidal as usual

Thanks for the pointer to the file and explanation Andrii. I’ll give it a shot because nothing else is working. All I’ve gotten from Roon support is a request for my logs (which I sent).

Well Andrii that was it! After I deleted the tidal account per you directions, Roon started and I simply logged back into Tidal. Thanks again for your help…much appreciated!

1 Like

I’m happy you solved this problem :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.