Stuck Snapshotting Database

Core Machine (Operating system/System info/Roon build number)

Windows 10 Home NUCi7 16 GB 512 GB SSD 2 TB SATA on current 64 bit Roon build

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

NUC Gb connection to Cisco switch and then Gb connection to Orbi router, Windows 10 home laptop and Pi 3 B+ WiFi connection to Orbi satellite

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Pi 3 B+ running RoPieee USB connection to Dragonfly Red

Description Of Issue

Roon user in US for just over a year. My library is just over 1,000 albums, 90% from Tidal. When I went to use Roon to play to my Pi DF Red endpoint my laptop and core both were displaying this message:


First time I have seen this message. I do have three backups scheduled including one to DropBox.

That was over 4 hours ago. No idea when message first appeard, my backups are scheduled between midnight and 6 am. Roon core using up to 40% of NUC CPU. Dashlane, Plex and Sophos Home running on NUC. All seem to be functioning normally.

What should I do to get rid of message and regain access to Roon?

Thanks … Tim

Hi @anon97951896,

Can you please try rebooting your Core to see if that has any effect? I have also gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.


Thanks @noris

I just closed Roon on my NUC and am rebooting now.

Roon ( full version not server ) closed promptly when I clicked on the X in the top right corner. When I went to restart I was prompted to apply some pending Windows updates. I did not know about them until just now, maybe they affected the database snapshot?

Roon restarted normally on my server after the reboot and is showing my Album page with 1,091 albums.

Roon started on my laptop and connected immediately to my core and I’m now playing to the Pi with the DF Red.

All three of my backups are scheduled to run every four days. One at 2 am, one at 3 am and one at 4 am. Last successful backups on May 11, May 9 and May 11.

The 3 am backup is the most likely candidate to have been running this morning.

I can’t remember if I stopped Roon before going to bed last night so it could have been playing when the snapshot kicked off. Hopefully the logs will show if I forgot and left music playing.

It looks like everything is back to normal after the reboot. I would have just rebooted before posting but I had never seen this error and did not find it when I searched the forum. Did not want to compromise my database.

Thanks again … Tim

Hi @anon97951896,

Thanks for letting me know that info. I can confirm that the logs have been received by our servers and I am not seeing any signs of corruption, but I am asking QA to double check this.

I would like to see if a manual backup will perhaps trigger this same behavior, can you please go into the backup manager and try triggering a manual one and let me know if that completes as expected?

– Noris


I just checked on the three scheduled backups I have setup and two of the three appear to have run and completed this morning without any issues. The time completed does not appear to be in my local time zone but I think I read something about that being a bug that’s being worked on.

The backup scheduled for 2:00 am Central time in the US to D:\RoonBackups completed at 21:01:03

The backup scheduled for 4:00 am to DropBox completed at 23:20:33

The backup scheduled for 3:00 am to E:\RoonBackups was last run on May 14th. I forced it to start at 10:06 am Central time. I saw the Snapshotting message for a few seconds and then it went away and the backup started preparing and then transferring. It completed at 5:07:19

Hopefully this is what you wanted me to do and not a manual backup using the Backup Now option.

Let me know if you need e to do anything else.

FYI … no issues with my Windows laptop or Pi, started playing to the Pi DF Red once the backup completed.

Thanks for your assistance … Tim

Having a machine in “pending update” state can cause weird issues at times, in my experience.

Hi @anon97951896,

Thanks for giving the automatic backup another try. You mentioned this:

For completeness here we should try a manual backup using the “Backup Now” option as well.

I believe it will work fine but it will be good to double check this as well, if this works as expected then it is possible the pending update was causing the strange behavior you noted.

– Noris


Thanks … my NUC is upstairs and runs headless so pending updates are just a fact of life. Its been running that way for over a year and this is the first time this has happened so hopefully it will be a while before it happens again.



Just did a manual backup to D:\TempBackup and it completed with no issues. The Snapshotting screen was displayed for about 5 seconds and then on to preparing and transferring. Backup completed at 9:00:33


Hi @anon97951896,

Thanks for confirming that aspect. I have added that as a note to your case and waiting for QA to give the final :+1: that everything is good to go and they have not further questions before marking this thread as [solved].

– Noris

Hi @anon97951896,

I just spoke to the QA team and they confirmed that there is nothing alarming in the diagnostics received. This issue may have been due the pending windows updates, but it is hard to say for sure.

I will go ahead and mark this thread as [Solved] for the time being but if this behavior occurs again in the future please do reach out to us again.


Thanks … Tim

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.