Stumped, can't get Roon to see HQplayer after changing IP address on Roon Core

I decided to try to isolate my music on my network and ran into a problem.

Here’s how I had it working, HQPlayer Desktop 4.10 connected to oR NAA:

Roon Core and HQplayer both loaded on Mac Mini M1, selected “local host” under “Add HQPlayer” in Roon Core settings:
IP Address of Mac Mini was
IP Address of OpticalRendu was

I created a new VLAN with only these two devices on it
Roon Core and HQplayer on Mac Mini M1
IP Address of Mac Mini
IP Address of OpticalRendu

Everything looked good, I could see both the oR and M1 on the network. HQplayer Desktop saw the oR. However, when I try to play a song in Roon, it says it cannot find HQplayer. I rebooted the router 5 times, Disconnected the oR 5 times as well. Still could not get Roon to see HQPlayer

I since restored my Network backup settings and everything works as it did. What step did I miss here? Did I need to add HQPlayer again on the Roon Core and select “local Host” again? Did Roon retain the ip address of even though it was changed to I could remote connect in to so it was indeed valid as was the IP Address of OpticalRendu of I restarted HQplayer NAA on the Rendu several times as well. Stumped…

VLAN shouldn’t affect functionality “localhost”.

But does internet connectivity still work on Mac Mini?

It sounds like you needed to have changed the ip address for HQplayer inside of Roon to it’s new IP address. vs

I didn’t check internet connectivity…I will try that tomorrow and report back

Since HQplayer and Roon reside on the same PC, it was set to “local host” in Roon with he original setup. I never had an ip address set, only had it as “local host”

“localhost” equals to IP address (IPv4) or ::1 (IPv6)