Stutters on all devices

Core Machine (Operating system/System info/Roon build number)
Windows 10
Dell XPS 13 - i7-5500U CPU @ 2.40GHz, 2394 Mhz, 2 Core(s), 4 Logical Processor(s)
RAM 8GB
Music on WD My Passport

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
500MB fiber, Wifi with signal boosters.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Node2I, Samsung S10, Klipsch Stadium .

Description Of Issue
Although Tidal Hifi and Spotify work flawlessly on all my devices, the playback via Roon keeps givings stutters on most of the songs.

Im going to suggest the wifi is the issue…especially if the core is also on wifi to the internet and the internal devices. Try using LAN for connection of the Core machine to your router/switch

https://kb.roonlabs.com/Networking_Best_Practices

  • Your Roon Core should always have a wired connection
  • If your library is stored elsewhere on the network, always ensure that both your Core and storage location are using a wired connection. Avoid WiFi between your Core and media storage at all costs.
  • Avoid connecting high resolution/high performance audio devices to Roon via WiFi to ensure optimal performance.
  • A wireless connection from your remote device to your Core is perfectly acceptable and expected in most cases.
2 Likes

Thank for the swift response, will give that a try and report back here!

Hi @Olaf,

I agree with wizardofoz’s recommendation here — As noted in our Networking Guide, using an Ethernet connection is always recommended. Try connecting the Core and an endpoint to the primary router via Ethernet and let us know how that goes.

You have with wi fi extenders ?

Maybe try

restarting them
Clear a path in front of the, my gas heater is a wonderful Faraday cage
If you can use the 5G channel there will be less interference, my microwave plays havoc

Ok so connected my laptop directly to my router and problem still continues. Only playback via Roon stutters. Sitting outside, connected via Wifi and both Tidal (HiFi setting) and Youtube music app (setting: Always high on WiFi) play flawless. Tried to play music stored on my laptop (both FLAC and MP3 files) as well as music stored on my 4TB WD passport but Roon keeps stuttering?

Pmease advise

Did you turn off the WiFi or make the Ethernet the primary connection?

Sorry not sure if i follow? How can i turn off wifi when i stream music to them? Those devices are meant to receive and play music via wifi. Please elaborate @support

Turn off WiFi on your laptop to ensure it’s not using WiFi. Your devices should access to WiFi on your router/ap not your laptop.

Ah sorry, yes that is off. Problem stays.

What WiFi setup are you using. What else is running on your core that could bog it down. Is it still importing music?

Can you screen shot the signal path when it’s happening.

Sorry but im not that savvy on setup of wifi etc. Just runnning wifi over one of the latest routers and extender. Input to router is 500mb fiber.

Core runs nothing else than Roon

Importing music couls be. Got close to a thousand albums on my WD My passport. But i assumed this could be done in 4/5 hours on 2cores setting.

“Screenshot signal path”, how to do that?

Check in settings library to see if it’s still doing analysis. Importing maybe finished but analysis takes much much longer especially on slower external drives.

If you have just loaded your library it may be still performing "Background Audio Analysis"on the audio files , see on mine 2 from the bottom there is no activity but you may see “analysing 123 form 1230” or the like. Its pretty processor intensive so it may cause skipping when it happens. You can set this to Throttle to release processing power but the analysis will take a lot longer. It can take literally days if its a big library.

Play something then in the bottom band on the screen you will see a little blue dot , click on it and you should get something like this

Try turning of Windows firewall or any software firewall to see if that helps. Often firewall settings can effect playback. If it does then ensure your letting all Roons processes through your firewall.

I would also ensure you dont have any VPN running just in case its slowing things up too.

Is off and doesn’t solve it, but thanks

As mentioned core is thebonly program running on the laptop but thanks

Ok well lets see this screen shots as we can tell a bit from them…also are you doing any DSP operations like convolution or upsampling etc?