Success with Tailscale VPN

Hi Pat

The iPhone output disappearing has happened to me too. I hadn’t made the connection that it was related to connecting to TailScale, but if it’s happened to you too that sounds like the common factor.

When it happens, eventually the iPhone reappears as an output and I can stream over TailScale. I just tested and it is working for me.

Interesting, I’ve left my iPhone on via tailscale for up to an hour and it never reappears as an output. Are you using an exit node on your network, so it’s actually still wifi? I am using Tailscale over 5G with no wifi at all. I am able to use the iPhone as a remote to control Roon that way, just not as an audio output.

Did you open up certain ports on your Roon core? I have a debian VM with Roon and tailscale installed. I did not do anything with firewall settings. I can on my iphone ping the tailscale ip of roon but the iphone roon app does not find the roon core

No, but I’m not using a VM.

@matt I haven’t had any luck with this - tailscale was running on both my iphone and my server (Ubuntu 18.04 LTS, Roon installed directly not in VM).

Can you share any further detail on your server setup (what OS, any changes made to your interfaces besides installing Tailscale)?

Has this worked on current version of Roon for anyone?

@Zaid_Haddadin I stopped using it because of this bug, so I don’t know if it works with the current version sorry

When I was using it, I didn’t make any changes to anything, it just worked out of the box - once Tailscaled was running on the server, it was automatically detected by roon. I’m running Arch linux.

Actually I just gave it another try. Yes it is still working (with the caveat of the bug I linked).

The only thing I can suggest is force Roon to look for a new server

I just gave a try to Tailscale without much luck. (Thanks for pointing us to this nice service).

My Mac Iphone would not discover the servers at all while my Mac would be able to connect (but with the “bug” that prevents from playing locally in the Roon App).

VPN connectivity is functional as I could connect from remote cellular network to internal server, but then Roon Client would fail finding the Roon Core server (from Iphone).

Could anyone with a working setup guide us further, please?

To me it is like Roon coders block the possibility to connect remotely, as soon as VPN (not just cellular) or similar is detected. Not sure what can justify this except may be a copyright issue, where content offered by Roon under license can only be viewed from within our private homes. I think I had read about this specific point in the past.

I’m interested in this functionality but right now I’ve focused on getting the core functionality to work at home. I’m plagued by the “media loading slowly” issue where my music stops, skips tracks etc.

Just tried this out and running tailscale on the Roon server broke all of my extensions. Currently have shut down tailscale and trying to get them back up and installed.

OK now I have removed tailscale and extensions are not showing up on the various devices on the network. Fun. Yes everything has been restarted.

1 Like

OK, it will not recognize the various extensions I have. It will flash a license manager for RooExtend but then it disappears immediately. It does not show/recognize the two RoPee displays I have on my network. I have entirely removed tailscale and still nothing. It looks like I’m going to restore the whole VM from last night’s backup.

I have Tailscale on a synology acting as a subnet router but my device (iPhone on cellular, running tailscale) would not connect to Roon core despite being able to ping its IP (local IP not tailscale IP).

Looks like the subnet router was the issue. After I restored it from backup I was still having the problem. I turned off the subnet router and extensions all started showing up.

So after looking online there were a few posts about some people having issues with the subnet router on Synology causing some issues that resembled mine. I turned off the routing on that tailscale instance, spun up a Ubuntu 22.04 VM, installed tailscale, set up subnet routing for the subnet all of my “production” computers, room endpoints and room core exist and… same problem.

Within a minute or two both of the RoPee displays start flashing and the extensions all start failing.

As soon as I turn off subnet routing everything works fine.

1 Like

I have the same issue. All is connected but I got stuck at “Looking for your Roon Core”

Looks like you guys should just use zero-tier. Seems to be far more success stories with this and roon, same ■■■■ really.

I’ve managed to make it work, I can see my Roon Core (installed on a Synology Nas) on my android. I’m connected to it with its tailscale IP, and it works on 5G, away from my network.
But my phone never appears as an audio output…
I’ve tried with exit node, but nothing change.
Has anybody found a solution for this ?

At this point there’s no solution and Roon support have said they aren’t going to fix it.

Tailscale doesn’t support roons archaic networking design aka multicast. It won’t work stop wasting your time and spend it lobbying roon to modernize their archaic multicast ■■■■ design

You are wrong, Roon’s multicast does work over Tailscale. The only thing that doesn’t work properly is local playback on an iPhone. Playback on every other device I’ve tested works perfectly, e.g. raspberry Pi, iMac. What’s more, playback on the iPhone does work intermittently, just not reliably. It doesn’t appear to be a networking issue, it looks like a bug only affecting local iPhone playback. This is why it’s particularly frustrating, because it seems like a bug in the iOS app Roon could fix without completely overhauling their networking.

Not say that Roon’s weird multicast streaming isn’t ■■■■ though.

1 Like

Actually I don’t think it does. Plenty of people still
Complaining it does not up until recently

But yea, roon needs to improve… fast. Imagine being on the board and not realizing your losing millions because all your future potential new subscribers cant use a service remotely outside the house which literally every single other product offers so they trial it and just think “what the **** this is useless” and go back to tidal/qobuz/Spotify/whatever works outside the house

1 Like

can you please share the working settings ?
You advertise exit node on the machine that is running the roon core ?
And the you join the exit node on the machine that is not on the roon network ?
Is that it ?

1 Like