Sudden loss of connection

Roon Core Machine

Zotac C1622 Nano running Roon Rock

Networking Gear & Setup Details

Primary Xfinity Cable box: Arris TG 168sG

Connected Audio Devices

USB: Mytek Brooklyn+ and Mytek Brooklyn

Number of Tracks in Library

Around 6000

Description of Issue

All of a sudden the USB connection between the ROCK server and the Mytek Brooklyn DAC (about 35 feet away) has failed. Since creating the connection a few months ago, I had not had any problems until this arose. I switch the system on one day, and the server could not locate the Brooklyn. The separate USB connection to the Mytek Brooklyn+ DAC (three feet away) continues to works just fine. I tried several different USB cables between the server and the Brooklyn without success. I’ve restarted the ROCK server several times and even reinstalled the operating system, also without success.

Hey @Daniel_Cole,

We’re so sorry to hear about the trouble! Thanks for letting us know though, as it gives us the chance to help. Also, we’re grateful you’ve already tried to resolve this.

I wonder, can your Mytek be updated to a latest firmware? Can you please also reboot the Mytek? If that doesn’t work, can you reset your modem & router?

That is quite a distance for a USB cable.
Was it getting power from the Brooklyn?
I wonder if anything changed on the Brooklyn end if so.

Any chance you could move it closer like the Brooklyn+ and see if it then works with a short cable?

It has the latest software. I have reset the modem and router a couple times.

1 Like

I haven’t experienced any problems with the cable run.
The problem could be on Mytek’s end. I’ve already contacted them, as well.

1 Like

But as a test could you move it closer to try the shorter usb cable?
More information never hurts if it is practical to try it.

Yeah, I’ve tried that. I also replaced the DAC with a different DAC, and it worked fine, which leads me to conclude that it’s a Mytek problem rather than a Roon problem.

Thanks for the help.

1 Like

So are you saying that when you moved the Brooklyn closer and connected with a short USB cable it worked fine?

If so that would indicate something changed at the Brooklyn as 35ft is really too long to work without additional 5v power.
It might have been on the edge to supply 5v over that distance and now cannot.

20 ft is usually about it for USB length, 25 ft at a push.
At 35ft at work we would be using a 15 and 20 with a powered junction in between.

Totally agree with both these points. Twenty-five feet is too long an unboosted USB run.

I’ve used this in the past with good results.

On another note, you may want a reclocker if you feel the SQ is being impacted.

1 Like

Thats a handy looking cable, might have to order one.
I bought from Amazon a 100ft USB cable which is actually 4 x25ft with powered junctions in between each 25ft run.
So it could be used as 50,75 or 100ft run.

Hey @Daniel_Cole,

Thanks for trying all these steps, and @AceRimmer and @xxx for sharing valuable info :nerd_face:

Please, @Daniel_Cole, let us know how things go with Mytek. Hopefully it’ll be a breeze to solve :pray: