Sudden Playback issue

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Roon has been playing fine then suddenly it won’t play when I skip a track or use Roon radio.
An album will play from start to finish ok but if I try to skip a track it says its playing but isn’t and I have to manually push pause then play to get track started.

2 posts were merged into an existing topic: What causes a track to get “stuck” at the end?

Do any of these issue questions ever get resolved by Roon!!

Of course they do.
There’s probably twenty or so completely unresolved posts at any moment in time.
Others are in the development queue or resolved through system config changes

1 Like

Yes they do. However, that doesn’t mean they won’t resurface at a later time for some other user, especially the ones that are network related or system related. Those that are Roon related, get fixed and included in the next Roon update.

Hello @Mark_Saunders1 I’ve merged your posts into one thread so that support can help you better. It’s best to have one thread, one issue.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hi @Mark_Saunders1,

Welcome to the forum! Can you please provide some more details regarding your setup?

  1. What kind of zone/DAC are you connecting to your PC? Please list the model/manufacturer and how it is connected to the Core.

  2. Does this issue impact multiple zones or just one zone in particular? If you don’t have other zones to test, you can try using the PC’s System Output zone which should output to it’s internal speakers.

  3. How does your network setup look like? Please provide model/manufacturer and if your PC is on WiFi or connected via Ethernet cable.

Once I have these details, I should be able to better advise, thanks!

Thanks for reply
DAC in PRIMARE i25 Amp
Only effects this zone when playing through chromecast
Airplay works ok on PRIMARE
Chrome cast works ok to tv zone
All connected through Ethernet
Was working fine suddenly started issue.

Hi @Mark_Saunders1,

Thanks for those details! A few questions:

  • Any change in behavior with a reboot of the Core / Primare?
  • Are you using latest firmware on Primare?
  • How is the network setup, is the Primare on Ethernet or WiFi?


No change following reboot
using latest updates
connected through ethernet.

im starting to suspect its a network issue with Primare. Cast works ok to TV from roon as does aiplay to the Primare.



1 Like

Thanks for those details @Mark_Saunders1!

I would try to cast to the Primare using another app to see if cast is impacted by multiple apps on it.

I would also try simplifying the network for the Primare - connect directly to router, try a different Ethernet cable / port.

You may also want to reach out to Primare support to get their thoughts on this as well.

Hi. I think I’ve pinpointed issue to iPad/IOS
I’ve downloaded google home, tidal and Roon remote to an android device and all seems to be working ok now.

Another issues I have sorry is Roon down samples all DSD files to pcm and all had files to 96khz. There also no DSD set up screen for the primare but it does play all these high res formats.

Any ideas please


Dit’s now started same issues through android so it is definitely a Roon issue as tidal working ok.

It’s now skippy through an entire album without playing any tracks!!

Hi. I think I may of worked out issue but not sure how to address it.

From reading a few Roon threads I’m starting to wonder if Roon is not recognising the DAC in my PRIMARE?

It seems to be an issue raised in several threads and I have had an issue relating to this before current problem.

Since I first installed Roon it hasn’t played any DSD files in natural format, always downsampling to 96khz pcm. It’s also does this with 192khz files and when setting up the amp in Roon there is no option for DSD set up?

This all suggests for what ever reason Roon does not recognise the DAC. Is this something you have come across before and do you have any ideas how to fix issue please?


Regards Mark

Hi @Mark_Saunders1,

This is expected behavior when you are using the Cast protocol, it does not support DSD playback.

Can you please let me know the exact local time + date + track/album you experience this behavior on?

Hi it’s doing it all the time no specific time or date sorry

Hi @Mark_Saunders1,

Please just let me know the next time you experience this issue (e.g. 1:24PM on 9/2/20 when trying to play Dark Side of the Moon) .

I would like to enable diagnostics mode for your account and what this does is upload a log set, but I need a timestamp + track to look for the issue.

16.08 gmt Alain’s morisette

Haven you any ideas of issue please yet? I think it maybe network issue but not sure.
Tried everything you suggested and still have same issue. I press play and it seems to play but no sound. I then push pause then play and it plays ok for one track then need to do the same for all tracks.
There is no specific time it’s all the time!

Hi @Mark_Saunders1,

Thanks for that timestamp, I can confirm that logs from your machine have been delivered to our servers.

We are looking into your report at this time, can you please confirm if you have noticed this issue only started to occur recently prior to our latest release or was it occurring on previous builds as well?