Suddenly cannot find core

I have been running Roon sever on a QNAP TS 473 without any issues for about 2 years. Last week the controller apps were suddenly unable to find the core. This occurs across an iPhone, iPad and Mac book air.
My NAS is connected to the network via ethernet. The other devices by wi fi. The Roon server is located on a 265 gb SSD and there is nothing else on that drive.
My main Room endpoint is a PS Audio Direct Stream DAC with Bridge. This works fine and I can play Tidal via MConnect.
My music is on a 1tb drive and there is about 250gb left. I have not added to this for some time.

I have tried updating the NAS firmware and Roon server. I have checked and there is no firewall running. I have uninstalled and reinstalled the Roon server, and restarted the NAS, but no change.

1 Like

Can you check if the Roon Core gets restarted? This is a normal effect if the core restarts frequently by itself due to memory issues (or other issues).

Hi, yes the Roon served is running and is connected to my database

Have you checked that your control devices are on the same subnet as your core, i.e. they’re all getting an IP address where the first three sets of numbers are the same? Something like 192.168.0.xxx

Also, if you haven’t already done so, it would be worth rebooting all your networking gear (router, switches etc).

My roon server is on a NAS. The NAS and my Roon controllers (iPad, iPhone) appear to have the same first three sets of numbers in their IP address.
I’ve reset my network devices but the problem persists.

I’ve just discovered something else, hopefully someone will understand what I mean and tell me whether my network settings are ok:

I’m using Qfinder Pro to login to my NAS. In Qfinder Pro the IP address is 192.168.0.xxx, which matches the IP address of my controllers, which include an iPad, iPhone, and MacBook Air.

When I click configuration on Qfinder Pro then Network Settings Obtain IP Address Settings Automatically Via DCHP is checked.

When I look into Details, System Settings, and Ethernet 2, it says it is up, DCHP is enabled, and I see the same IP address first three sets of numbers, and the same Subnet Mask as my controller devices.

I don’t know much about networking but it seems to me that everything matches.

I’ve tried manually entering the NAS IP address into the Roon Core Search Window and it still doesn’t find anything,

Can anyone help?

How do I escalate my issue to Roon? I don’t seem to be able to get a solution here. Thanks

I know this may sound silly but try changing the DNS on your router to 8.8.8.8 or 9.9.9.9

Reboot your network and then your NAS and cross your fingers.

It’s the weekend, but tagging @support.

Thanks I’ll give it a try. A quick question though, do it need to also change my iPad to 8.8.8.8. And it works will I have to change every device on my network to 8.8.8.8?

1 Like

Just the router

1 Like

The only other devices you would need to change are ones where you manually set a DNS server. If you haven’t done this, i.e. all your devices obtain the DNS address from the router, you shouldn’t need to change anything else.

1 Like

So it seems that my ISP locks certain functions on the router to prevent people changing things like the DNS. As such I can allocate a new DNS to my router

I have a mesh network—Google WiFi— which takes its signal from my ISP. I thus change the DNS on Google WiFi. You might consider a mesh network for this and other reasons.

Thanks so much for all you help here Michael, I’m very grateful. I have a mesh router system, TP-LInk Deco M5s. I also have my home security and intercom set up on the network, and for reasons I don’t understand the mesh system had to be set up in access mode for the security and intercom to work, even though these things all gone into a switch and the mesh system runs directly off the modem. Anyway the upshot is I can’t alter the DNS on the mesh system either because it is in access mode. Blimey.
I tried connecting my NAS directly into one of the modem ethernet sockets rather than the switch but it didn’t make it any difference to the issue. The controllers still can’t find the core.
This all worked perfectly for the last year.

1 Like

@support

Is there anyone at Roon who can help with this. It’s been an issue for a number of weeks and I dont seem to be able to find a solution

Hey @Tony_Merritt,

Ben with the Support Team here, thank you for taking the time to reach out and provide us with all of the information above! I really appreciate your patience, and completely understand how frustrating it can be running into issues related to your Core.

With the information you’ve provided above, the next step would be for the Technical Support team to review a set of your Core logs to check for any inconsistencies. When you have a chance, can you please follow the instructions here and send over a set of logs to our File Uploader?

You can download your logs by clicking the “Ambulance” button from your Roon overview on your QNAP:

image

I do want to make a point in saying that running Roon on a NAS is oftentimes not an optimal experience overall, and something to potentially keep in mind for future consideration. You will have a much better experience with a different type of Core.

Let me know when you’ve submitted your logs for our team to investigate. Thanks!

1 Like

Hi Ben, when I purchased Roon the Roon site recommended using a NAS ands recommended the exact QNAP NAS that I bought. I spent a significant amount of money buying the exact one that was recommended. It is very disappointing to say the least that Roo.n has now changed it’s mind about this.
I will upload the zip file now.
However, now when I open Roon controller on any of my devices it asks me to log in to Roon, and when I do using the correct email and password it says that I cannot login because I am already signed in. If I select Go back twice it shows my NAS and offers a Connect button, but when I hit the button this process is repeated. This is incredibly frustrating.

I used to have a Qnap, It had four network ports and I connected two in failover and bounded them together so both used the same IP. (requires a managed switch) Simply disconnect one of two network cables at the back and make that your default connection. (restart first might be enough)
It is best to reach out to Qnap if you need more help. They teamviewer in and you watch them work.

So basically Roon-core has started to use another IP address and your remotes are still looking for it at original address. If you are only using one network cable you might need to call Qnap (they have offices in USA). They might not be able to Teamviewer in then either. You also need to update the Roon app manually (or did a couple of years ago).

In my case it was up to Bryston the fix the BR-20 and Roon to certify it. So if BR-20 doesn’t work or does unexpected things we go in Brystons forum to let them know.

PS
Changing your public DNS server might help webpages load faster but will not help this problem as you mentioned both IP Addresses start with the first three octets the same and thats a private IP range.

Good Luck