Suddenly Roon on Qnap hangs when playing m4a files

@nuwriy, @Rory_Norman, I installed Roon on Linux VM (ubuntu 20.04) and copy two types of files (only few files, not the entire collection) and it seems to play all files.

Maybe testing ffmpeg on Qnap is a good way to continue debugging?

1 Like

I tried this using the ffmpeg in qnap:

 # ffmpeg -i 1-02\ Rambi.m4a -c:a flac /tmp/audio.flac
Decoder (codec aac) not found for input stream #0:0

On other type of files (e.g. mp3) it does work.

@support, @nuwriy is this something you’re using? If I’ll try to contact Qnap with this issue, will it also fix this?

Update: I opened a ticket with Qnap on this.

I am also currently writing with QNAP about this issue.


@Rory_Norman and whoever else is having this issue. @crieke tested with custom ffmpeg and indeed this was the problem. I guess a solution is on the way :slight_smile:.


Thanks. Looks like our problem is part of a broader one that has been plaguing people for a month or so. Maybe a lot of people will be cheering when we get a solution.


same issue here

i have QNAP core

AAC radio streams do not work

also AAC streams from tidal do not work

i dont have any local ac files, only flac and mp3 these work perfectly fine

i need to restart the endpoint (Naim uniti atom) to stream something else whenever this issue occurs

lets hope a qnap update solves this indeed

Same problem here! This cannot be… just wait it out… How can a simple update mess up half of the library?! I am seriously considering to just drop Roon. Listening to music should be relaxing. You pop in a track and it works every single time. It cannot be hitting play and worry about if any of the recent update caused compatibility issue with 1 piece of technology within the dozen that make up the music delivery system. This completely spoiled the whole music listening experience.

Honestly, I rather go back to the trusted CD player. It is totally reliable. It plays full range of sound and not having to worry about flac, and any sorts of file conversion issue, NAS, etc. etc. It is $10 without any of the grief. If I want music everywhere I just go with Tidal and let them figure out this BS maintaining different format of the music file. What a joke! Since when listening to music requires any of these hassle!!!

1 Like

Just an update, The support representative from Qnap said that he’s transferring the data to R&D to fix - they are aware of several issues opened in this forum because of this problem. Not sure how long will it take.

I guess it’s a legal issue that prevents Roon from distributing ffmpeg themselves.

FYI @goat, @Tony_Tsai, @Rory_Norman and @crieke.


Thank you Haim for initiating this conversation with Roon and t-shoot.

Well this has nothing to do with Roon…
Its a qnap issue in their latest firmware

Apple had similar issues going on with s huge osx update, all audio software was impacted for a month…

Microsoft also did something similar when suddenly after a windows 10 update the media pack was not ready and roon wouldn’t start… Also on that case all audio software was impacted…

I guess that’s what we get when updating always directly to the newest version…
(But as an it guy, I also always want to check out the new stuff)

Well, there’s also another way to look at it. If you totally depend on some component that is so vital to your application and is not considered to be hard core system stuff (like file systems, memory management etc) you could either write it yourself, or if there’s an existing component available you can include it in your distribution - of-course there are legal implications and you might need to reach an agreement with the developer of this component. At least on my mac there are several music converter (free and commercial) who redistribute ffmpeg.

Having said that, The only real complaint I have to Roon support is that they didn’t give the impression that they are really looking into it. @nuwriy did ask for details after a couple of days but a simple response that says “I got you’re input, please allow a few days to investigate” would give me much better feeling that someone is handling this. Maybe they did look into it, but they didn’t say anything - from my point of view they could have just missed my answer :frowning:. The first time I felt that someone is really taking care of it is when @crieke joined the discussion (and thanks again).

Regardless of all the above, I hope we will have a solution soon (either by Qnap releasing a fix or Roon including ffmpeg).

I had the same problem, in a different thread.
I temporarily fixed it by updating ffmpeg.

It would be good if Roon gave the impression of taking this seriously - even though it only impacts QNAP users this time and we are a small subset of users.


Hi everyone,

I just wanted to let everyone know that we are looking into this with QNAP. We can’t provide any specific timelines just yet, but as soon as we have more information we’ll be sure to let everyone know.

Thanks for your patience and understanding while we work with QNAP to get to the bottom of this.



Thanks for letting us know.

Thanks @Bart_Maguire that was very useful. I have now fixed it too, although I copied the new ffmpeg file in place of the old one, rather than update the PATH.

Here are the detailed steps to fix it (command line knowledge required)…

  1. Enable the QNAP Club repository in the App Center (if not already done)

Instructions here…

  1. Go to the new repo in App Center and install ffmpeg - this will install version 4.3

  2. Open a SSH (putty) session

  3. Find where the current version of ffmpeg lives, mine (v3.3.6) was installed here…

cd /usr/local/medialibrary/bin

  1. Rename it to ffmpeg_OLD

mv ffmpeg ffmpeg_OLD

  1. Go to the location of the new version

cd /opt/ffmpeg

  1. copy it into /usr/local/medialibrary/bin (or wherever your original ffmpeg was located)

cp ffmpeg /usr/local/medialibrary/bin/.

  1. Restart the Roon Core

  2. Hopefully should now play AAC files. If you have any issues, rename ffmpeg_OLD back to ffmpeg again.

It looks like the QNAP installed version of ffmpeg has been compiled with most of the decoders disabled so hopefully they will fix this soon.


Have fix it too, thank you!!!

1 Like

Confirm this appears to fix the AAC live radio stream issue as well.

1 Like

This also solved the same problem for me - thanks.

Come on QNAP - given the fact you actively promote Roon core capabilities of your NAS products, you should be doing better than this


Big thanks to your detailed guidance, helped me to make it work again.



This is brilliant!!! After MONTHS of seeing half of my library gone into crap this finally is the solution that fixed it!!! Need some UNIX background in order to execute this solution though … not for the typical users. I still don’t get the relationship between Roon and QNAP. Isn’t this something they should be working it out together? It seems QNAP couldn’t care the impact of their change to downstream/depending users. And Roon doesn’t care to make this solution more accessible to the population of Roon users on QNAP platform. User suffers. It’s pretty sad.

Thanks again Daniel.


1 Like