Suggestions For Dealing With A Sub Par DAC

I bought a Chromecast Audio device after the update that added support for it and hooked it up using its analog connection to a Samsung HW-J7500 soundbar to get a Roon endpoint in my office. The soundbar also supports optical input so I purchased an optical cable to see if it sounded better than the analog input.

What I found was that when the CCA was using its optical output and functioning as a transport forwarding on to the DAC in my soundbar it would forward tracks at rates that the DAC in the soundbar could not handle so those tracks were played by Roon but produced no sound from my soundbar. Not a good result especially when in Radio mode.

I’ve switched back to using the analog output from the CCA for now but I wonder if using the optical output might sound better even though in my case it would need to be restricted to 48 kHz 24bit.

I understand this is a soundbar problem, not a Roon or CCA problem. I’m also assuming that there could be other cases where using a transport ( not necessarily a CCA ) to talk to a DAC ( not necessarily a soundbar ) could have this same problem.

I’m wondering if there is a way in Roon to restrict the output to this one CCA device to 48 kHz 24bit so I can try using the optical output and see if I like it better?

Thanks … Tim

Yes, you can override the maximum sample rate allowed in the audio settings advanced section for the device.


Thanks for the suggestion. Unfortunately, it looks like that option is not available for a CCA device.

The option is there for my DragonFly Black.


Hello @anon97951896,

At the moment, we do not have a mechanism to set a maximum sample rate or bit depth to Chromecast devices. I will forward this as a feature request to the development team. In the meantime, you should be able to accomplish the same functionality by using the Sample Rate Conversion feature in Roon’s DSP Engine. In the configuration, set the “Sample Rate Conversion” to “Custom”. Then, you can create rules for sample rates higher than 48 kHz to automatically resample to the lower rates.


1 Like

Try looking in the DSP engine does that give you downsampling options as well as upsampling? I’m away at the moment so cant check myself.

You need to use Roon’s DSP engine to set up conditional sample rate conversion.


Or if your soundbar has an HDMI input, just get a standard Chromecast. Roon automatically will downsample to max 48 kHz.


John / Simon / Andrew,

I will check out the DSP settings for the CCA.



While my soundbar does have an HDMI input it’s in use and I don’t have a standard Chromecast device. If I can get the DSP engine to work great and if not I’ll just stick with the analog connection.



Using the DSP engine worked. All my sample tracks higher than 48 kHz that did not play before now play after being downsampled to 44.1 / 48 kHz.

Thanks … Tim