#support need help connecting new Roon Nucleus

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Modem Arris SB6190
Ethernet switch: Netgear 5 port gigabit ethernet switch GS605v5

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Lampizator Amber 3

Description Of Issue

I just received my new Roon Nucleus and trying to connect for the first time. I have been using Roon on my Windows laptop (Windows 10 version 1909) and controlling using the Roon software on my pc and the Roon app on my ipdad. I was streaming through a PS Audio DSD Jr. and then more recently with a Lampizator Amber 3. All worked well.
I tried to install the Roon Nucleus today and the Roon app cannot find the Nucleus. Internet connection works so not sure what I am doing wrong.
Thanks in advance for the assistance.

1 Like

Hello @john_dottore,

When the Nucleus+ is powered on do you see the LEDs of the ethernet port lit up? It could be a lose connection somewhere.

Another possibility is that you have some sort of firewall preventing your PC from seeing the Nucleus. Ensure you’ve disabled the Windows Firewall settings as well as any antivirus programs.

If fiddling with the ethernet port and firewall doesn’t make your Nucleus+ visible on the network, I would try connecting the Nucleus+ to a TV or Monitor via an HDMI cable and checking the on-screen diagnostics. Ideally you’d have ethernet connected during this test so that you could see the Nucleus+ pulling an IP address.


I turned the firewalls off and no luck. I cant connect to a tv and ethernet at the sane time. My pc has an HDMI connection, can I connect to the PC to see the on screen diagnostics?

Hello @john_dottore,

It’s okay if you can’t connect both at the same time. The diagnostics screen will tell us if the Nucleus+ is “healthy” or not. If you see it asking you to connect to the network, we can assume that it’s alive and kicking and start troubleshooting elsewhere.

If your monitor is connected to your PC via an HDMI cable, it should be safe to disconnect the cable from your PC and plug it into the nucleus temporarily.


I connected to the tv monitor and the on screen info is:

Manufacturer: Roon Labs
Model: Nucleus
OS: RoonOS 1.0(build 175) stable
Hostname: Nucleus
Serching for network address…

If this persists, please check your network connection

Hello @john_dottore,

This is good news, it means that your Nucleus+ hardware is functioning correctly. You’re free to disconnect the Nucleus+ and bring it back to its intended final location.

Once the unit is back where it belongs, reconnect the power and ethernet and confirm that you are seeing the ethernet LEDs light up green or orange on the rear of the unit.

If the LEDs are lit and you still cannot see it in the “Select a Core” list in Roon on your PC, I’d recommend trying a smartphone or tablet running the Roon Remote app to see if the Nucleus+ is visible there.

Should it again not appear in the Roon Remote app, I would go ahead and install the “Fing” network scanner to see if you can see the Nucleus on the network at all.


The lights are on at the ethernet connection.
I installed Feng and don’t see the Nucleus listed when I scanned for devices. I did not tell you earlier but I have an Eero mesh network and I think the Nuclues shows up on the list of connected devices. It shows a device call Linux-10… Is it possible the Nucleus is trying to connect via wifi instead of via the ethernet cable?

actually i think the device showing as Linux 10 is an Amazon Echo not the Nucleus

also never mind my Eero wifi comment. I forgot to mention my modem is connected to an Eero mesh network router via ethernet which is in turn connected to the netgear ethernet switch.

I still need help with this issue. I do not see the Nucleus on my network. I do see the “select a Core” on my laptop however when i click on that it gets stuck in the search mode and never shows that it is finding the core. The same happens on my ipdad.


If as you state above you are seeing “searching for an IP address” then your Nucleus is not on your network. Check your cable and try moving the Nucleus to your ISP provided router and see what happens then. Once the Nucleus is assigned an IP it should work.

I can now see the Nucleus on my network. I am now having issues with the Roon software on my Windows laptop and ipad. When I try to launch Roon it keeps shutting down and does not give me enough time to click on configure button. I completely uninstalled and reinstalled Roon twice and still have the same issue .

On the ipad Roon brings me to “software update needed” and when i click on Remote Core (Nucleus) it gets stuck on "checking for update… and wont advance.


Forgot to mention on my ipad the system status page shows the Nucleus Operating System, Roon Software, Roon Server Software and Roon Database settings all with OK status.

Problem solved and I am now running Roon through the Nucleus ! Thanks for your help.

1 Like

Hi @john_dottore,

Thanks for letting us know you were able to resolve this issue!
If you run into any other difficulties with Roon, please just let us know!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.