Surround sound on MacMini

I have asked a similar question once before but it was never resolved. In the meantime new options have appeared in the Roon setup and I am even more stumped than I was before. This is what I am trying to accomplish.

Roon runs on a MacMini.

When I try to play 2 channel sound I would like to have it rendered as surround sound. If I go to Roon > Settings > Audio and I chose the HDMI output that links the MacMini to the AV Receiver and then Device Setup, one of the Advanced Options is “Send stereo/mono content as 7.1”. I have set it to “Yes” but still only get stereo. (“Channel Layout” is set to 7.1). What am I doing wrong?

Oops, I just discovered that what I am actually getting is 5.1 but I wasn’t hearing it because only the front and the rear speakers were firing. When I set “Swap Rear and Surround Channels” to “yes” I do hear it as surround, so let me rephrase my question: why do I only get 5.1 when the option is given as “Send stereo/mono content as 7.1”?

Big bummer. I mistakenly fed the system a 5.0 track, so please ignore my earlier remarks. This, however, makes matters much worse because despite the “Send stereo/mono content as 7.1” it is actually being send as stereo (accompanied possibly by 5 silent channels). What is the point of these Roon settings. Why can’t I get the sound my system is capable of delivering?

Hello @Luke23,

  1. What make/model is your receiver? Generally, I would recommend using the built in surround up-mixing features of most AVR’s, they may have model specific tweaks that would provide for a better experience.
  2. If you’d like to up-mix the content to use all of your speakers in Roon, you need to use the DSP Engine to do this. In the DSP Engine screen, click the Add Filter button and choose Procedural EQ. In the Procedural EQ screen, click Add Operation and then Mix. Then, you can click the Add Mixing Rule button to create extra channel mappings.


Hi John,

My AVR is a Denon AVR-X7200WA and I quite agree about using it to do the upmixing. I like what it produces. The problem is when I run Roon on bootcamp I have no such problems. All signals are simply passed on to the receiver as they are, but this does not happen when I run Roon in OSX High Sierra.

If I have to go into the DSP to accomplish upmixing what then is the point of “Send stereo/mono content as 7.1”? What does it do, if anything?

Hello @Luke23 ,

In the device setup screen for the HDMI output, make sure you have “Exclusive Mode enabled” and Channel Layout set to “2.0”. This should send a two channel stream to your Denon allowing it to use it’s own processing.

The reason for this option is that some receivers will malfunction when not sent a multi-channel stream. It’s a fallback to allow Roon to play to these devices.


Hi John,

Yes I know about this option, but the problem is that I have a mix of multi-channel and stereo material in a variety of resolutions and when I set Roon up in the way you suggest everything is reduced to stereo. What I want is what I can do with Roon in Windows and that is set it up in such a way that Roon simply passes the signal on over HDMI as it is, so multichannel when it is multi-channel and stereo when it is stereo. For reasons that I do not yet fully understand this does not work in High Sierra.

In reply to Dylan (here: White screen, slow).

The AVR is a Denon AVR-X7200WA. It is attached on the HDMI port to a MacMini (with bootcamp Windows 7) on which I run Roon server and client. This machine serves the rest of the house (Sonos and raspberry). There are two fundamental problems, neither of which I seem to be able to solve. The first is a Roon one, the second is a MacMini one. Since the last is the most fundamental, let’s start with that.

Appears to be unable to pass sound through without changing it. The Audio Mini Setup app allows one to choose the output connection (in my case HDMI) and the number of channels. When I choose multi-channel (7.1) and I play 2 channel music on the Mini (it doesn’t matter with what program) my AVR is passed a multi-channel track consisting of 6 silent channels and two stereo channels of music. Consequently it is unable to use that signal to produce simulated Dolby surround (which it does extremely well, which is why I want it). If I play multi-channel music, there is no problem. Alternatively, if I use the Audio Mini Setup app to set the output to 2 channels, than the Dolby Surround upmixing works but all my multi-channel music is turned into stereo.

In Windows bootcamp this does NOT happen. The signal is simply passed on to the AVR “as is”. So a stereo signal is nicely upmixed (if so desired) to Dolby Surround and any multi-channel material is played as such.

I have yet to find a way to force OSX to output a signal “as is”.

My problem with Roon is sketched in an earlier mail in this thread. If I go to Roon > Settings > Audio and I chose the HDMI output that links the MacMini to the AV Receiver and then Device Setup, one of the Advanced Options is “Send stereo/mono content as 7.1”. This would be the second best option (the first being the upmixing by the receiver itself). However, when I I set this option to “Yes” nothing happens and I still only get stereo. (“Channel Layout” is set to 7.1 and the Audio Mini Setup app has been set to 7.1 as well). What am I doing wrong?

Apologies for the long mail, but it is a thorny problem and not easy to explain.

Hey @Luke23,

Thank you for the details here! I wanted to reach out because we were able to to reproduce the behavior you are seeing on MacOS, however the tech team has let me know that this is in fact a limitation of MacOS. We’re going to investigate if we can do better here if possible.

I see that you posted in the other thread mentioning that you were able to get up and running with Windows 7, which is great! I’m glad you were able to get that working. If you have any other questions about that just let me know!

Happy listening!


Thanks for the follow up. Just to be absolutely clear, also to those that run into similar problems and read this thread, what you are saying is that as far as the Roon problem is concerned, the setting “Send stereo/mono content as 7.1” does not work on a Mac. If that is the case, why offer it?