Switching Core PC & Clarification on How Remotes Work [Remote Connection]

Tried assigning a static IP, still NG (forgot what a PITA that Asus router software is, no wonder people hack it with Tomato). I took a screen shot of core’s storage tab (not sure why you wanted that) and of the error message on the iPad (there must be some nifty app for capturing screen shots on the iPad but I don’t know or have it so photo will have to do). Not sure how to upload images to this forum though.

I was working with the Roon Dev’s for 4 hours last night, through to 0100hrs, working on this problem, which may be similar to yours.
Several bugs found, which will apparently be dealt with very soon.
Contact @mike and @vova for more details.

Don’t worry about the screenshot at this stage David. Sounds like a known issue that’s getting fixed.

The storage tab shows the paths to organised and watched folders. Sometimes that helps understand connection problems.

You can upload images to the forum using the icon with the up arrow in the editor.

I hope this can be fixed for you shortly.

Yes I see that now, before I start typing. Would that known issue be with the Roon core program or the tablet app?

Perhaps. But I’m still getting “connection failed” after turning remote access off then on.

I reported this on the 27th August. Frustration is not the word…
But as I clearly wrote above - contact the Roon team if you want more information - the bugs will apparently be dealt with soon (note emphasis).

We have a release in testing right now with fixes for a few tricky bugs related to this issue.

@rolski was incredibly patient and helpful, and we finally were able to see this issue after weeks trying to reproduce internally without success.

Hoping to get the release live in the next few days guys – as always, thanks for your patience.

I tried barking up another wrong tree today (in case your new release doesn’t fix my problem): it occurred to me maybe the Windows 8 security model doesn’t like programs run by non-administrators accepting outside connections. I tried running as administrator and I tried deleting from the normal user account and installing under the administrator account. Still no good.

That leads me to ask, though, why the heck you’re installing your executable under the logged in user’s app data directory, which is normally hidden, instead of in the programs directories. It confused me the first time I ran the installation under an administrator account, as is customary, then switched to the normal user account and couldn’t find the program anywhere! I understand there may be several people using the same machine, each with their own music collection, but isn’t that what profiles are for? Also, presumably if you switched users instead of logging out you could have several instances of Roon running on the same machine, but only one could be core. I ruled that possibility out too.

For now I moved my core back to the Windows 7 laptop, which still accepts remote connections fine… I’ll be happy to test your release when it comes out.

For many years apps that are meant to be local to user (and updatable by user without UAC prompts) belong in LocalAppData. For years, Chrome used to install there, as well any applications using the Microsoft ClickOnce mechanism.

By the way, this bug has been fixed and just needs to be rolled out. The issue will be very difficult to work around :frowning: Waiting for a build will help save your sanity.

Hello @Leporello are you still having the connectivity issue ? Yesterday we’ve released a new build, try to update your client. If the issue persists feel free to ping me and I’ll try to help you.


The behavior is more or less the same. The remote searches for “libraries”. If I diddle with the core machine (perhaps restart Roon or toggle “accept connections” off and on) it sees the core machine but still fails to connect.

But your terminology is confusing. You say update my “client”. I updated the core machine, but there doesn’t seem to be an update for the iPad remote app.

I can try setting up the laptop again as remote with the new build–previously it had behaved the same as the iPad–but that still doesn’t get me to where I want to be.

Is there a way to tell when there is a new build other than downloading and installing it? The Windows file is just called “RoonInstaller.exe”. The creation date gets set to the time of download. I can double check I didn’t install a previously downloaded version.

If I knew for a fact installing Windows 7 on the HTPC would fix the problem I would buy a copy. I dislike 8.1. Better still, Ubuntu desktop. I know the consensus among Linux lovers seems to be to concentrate on headless server for NAS and Raspberry Pi-like endpoints–both of which interest me also-- but I would far rather use Linux than Windows for my core machine, for any number of reasons. I realize this would come with a whole new debugging cycle.

Verified: using ver. 1.1 build 65 as core on the HTPC under Windows 8.1, and as remote on the laptop under Windows 7, the remote connection still fails.

Hello @Leporello thanks for the feedback. To get more sens of what is going on I need to look through your logs. I’ll PM you shortly with further instructions.

I should probably update this. I nuked the HTPC and installed a found copy of Windows 7 Home Premium, and Roon is working fine for me. Don’t know what the connectivity issue was, but don’t care now. I would love to switch the whole HTPC to Ubuntu or something, but for now this is working for me.

Thanks for update @Leporello, Linux version of RoonServer is on the Roadmap.