Switching Playback Devices

I am running Roon Core on my iMac Pro until my Nucleus + comes in a week or so. I have this connected to my Chord Hugo TT 2 via a long USB cable. I also sometimes play back using the speakers on the iMac Pro. I have noticed if I want to change the output device from the iMac Pro to the DAC what happens is that the just makes a loud squealing noise, even if I wait several seconds. The way I have found to fix this is to stop and restart the Roon UI on my desktop. Is this a bug or some other problem?

Hi @Jon_Saperia,

Does this same behavior occur if you connect this device to a different machine via USB?

Can you say what you mean by “this device” my iMac? I guess i have different endpoints, but not via usb.

Hi @Jon_Saperia,

Apologies, I should have been more clear. By “this device” I meant the Chord Hugo TT 2 mentioned above that you’re experiencing this issue with.

Ah… Thanks

The TT2 is the only DAC I have so I guess I will have to wait until the Nucleus + ships (hopefully this Friday). That will eliminate a long cable and the iMac from the picture completely.

Hi @Jon_Saperia,

Let us know how this test goes! It will definitely be a good data point in understanding where this issue is stemming from.

Does the device eventually work after the noise is made, or does the noise continue once in this state?

The sequence is I leave the DAC on - in fact I touch nothing on that device. I quit the Roon UI on the iMac Pro which is also where the Roon Core is executing. When I restart it and press play all is good. This seems to be a problem switching zones - or at least switching from the same machine the Core is executing on to a Zone connected via USB to the system running the Core.

If all goes well, I should be able to update this in about a week.

Thanks for the update, @Jon_Saperia.

I spoke with the tech team about this, and they agreed that the best next step here is to try this out with another Core. Once the Nucleus arrives please let us know if you’re seeing the same behavior.

@dylan - I just installed the Nucleus + and changed that to be the core device. When I went as far as setting up tidal since I have not moved my library to the internal disk I just installed in the Nucleus + ./

I had to stop and start the UI twice to get rid of the same problem… Very low signal level with a hissing/squeal. So I am not sure what the problem is here.

Also there were many other problems with the Nucleus thyat I will detail later.,

Hi @Jon_Saperia,

Can you reproduce this issue once more with the Nucleus and make a note of the time that it occurs? Once you’ve done so please respond here with that time and we’ll enable diagnostics so we can take a look at what was occurring with this device connected to the Nucleus.

Hi @dylan. I could not reproduce this with the core running on the Nucleus +, It last occured when I switched from the core runnin on my iMac Pro to the Nucleus +. It appears then that this issue is when core is also running on the iMac Pro.

Also I see that the user interface is different. Before when I wanted to switch playing music to a different zone that was already playing on a zone, I would click on the music and/or zone that i desired. I just don’t remember the exact sequence and am sorry about that. What I can tell you is that just now (about 9:40) Mountain time, I transferred by right clicking on the icon of the zone (output device) to get a list of available zones. That worked well…

I am sorry I could not reproduce this with the Nucleus +. I guess this is helpful since it points to code with core on the iMac Pro.

Hi @Jon_Saperia,

Thanks for the update! It sounds like things are working well with the Nucleus, then. If you do experience this issue with the Nucleus at some point, make a note of that time and respond here and we’ll take a closer look.

Hi @dylan, thank you. I will let you know if there are any other problems like this.

@dylan - I just ran into the problem where you get mostly fuzz coming out of the system with the music in the background. I had not switched zones. The state was that I had been ripping CDs to the internal disc and wanted to hear some. I had been using the Roon UI on my desktop. I selected an item to play on my iPhone (6s Plus) with the UI running there. Both the desktop and the iPhone we on the same zone. When this happened, I reselected the zone, I paused the music, reselected the zone on the iPhone and things cleared up. Sooooo… this appears to be a general Roon problem, rather than an issue specific to the core running on my iMac Pro.

Hi @Jon_Saperia,

It sounds like this was a bit different than what was reported before, correct?

Rather than a noise when switching Zones, this was a constant static/fuzz sound that didn’t go away until the Zone was re-selected?

Which Zone was this? Has it happened multiple times? Have you noticed any patterns in what seems to get this to occur?

This seems like the same to me. The issue seems to be when you contact the core system from a different UI that is controlling a zone from a different Ui also connected to the same zone - it does not happen when you use transfer zone rather than just clicking on a zone or pressing play from a different Ui pointed at the same zone

Hi @Jon_Saperia,

The next time this occurs can you make a note of the time and respond here with that time in your local timezone? Once we have this we will enable diagnostics for the technical team to take a look at.


OK, if you look at my posting about 4 days ago you will probably be able to figure out the time. If that does not work, I will let you know as soon as it happens again.

Hi This just happened, though I may have been going on for some time. I was using Roon to listen to my iPhone this morning and just got back to my office to listen the zone was set, because I had not changed it on my desktop to my hugo TT2. When I tried to switch zones to use the TT2 again, it did not help. I just checked to see if my iPhone had switch from it to the hugo tt 2 and it had not. Shutting down the UI on my desktop did not help. When I restarted roon on my desktop, still the distortion was there. My local time is 2:33 Mountain time. I am going to reboot the Nucleus + next. That fixed the problem.

Thanks, @Jon_Saperia.

Thanks! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.