Synology cant move the database to a USB SSD

Bought a 220+ very happy with roon on it, but looking to see what an SSD would do. I have tried uninstalling and re-installing the roon package but it returns with the old configuration of the data base on the drive, and doesn’t give me the opportunity to restore it from backup to a USBSSD. Is this even possible?

A question best answered by @crieke Chris I think

Hi Mark,

I think you did not explicitly created the shared folder RoonServer on the USB SSD. Probably Roon is still using the shared folder RoonServer in the volume on your harddisk(s).

I give you global steps to solve this problem. Hopefully this is a enough for you.

  • frist, stop the Roon pakage
  • rename the share folder RoonServer to someting else, for example RoonServer-Old (so you can always go back)
  • create a new shared folder in the volume on the USB SSD with the name RoonServer
  • start the Roon package again
  • restore a backup
  • if Roon is running correct you can delete the shared folder RoonServer-Old

Succes!

On my DS1513+, I moved Roon DB folder to SSD and this worked for me as suggested by @crieke
I’d recommend to format the drive with a ext4 filesystem
After that, first stop Roon Server and rename the old shared folder to anything else.
Then rename the external SSD disk to “RoonServer”.
You can copy all folders from your old database to the SSD.

Another (and my preferred) option is, to use Roon’s backup feature and create a backup before you start the above process and restore it again with Roon after you’ve renamed your old shared folder and the new SSD.

1 Like