Synology NAS Experience (problems with DS218+)

Hello All. I am hoping I can get recommendations for making a Synology NAS work (purely as a file server) for Roon. I already have an I7 NUC to do the heavy lifting, but my DS218+ Synology NAS apparently is not up to the task of promptly serving files to the NUC (I get typical 14-second delays in loading files, but no delays using Tidal). I understand that this is because Roon performs multiple processing on the source file - whereas simpler user interfaces (like BlueOS) just take the file from my NAS with no delay. This additional processing is apparently key to Roon’s functionality, and is therefore unavoidable. I could ditch the NAS and simply use a USB drive hooked up to my NUC, but I like having a NAS in my home.

Apparently, the issue with the DS218+ is not enough processing power with its Celeron chipset. Can anybody using a Synology NAS as a file server for Roon (i.e. not running Roon itself) tell me what models, or what specs, work?

As an add-on to this discussion, if I am upgrading my NAS to one with more firepower, should I consider just running Roon on the NAS instead of the NUC? Somehow, I’m thinking I will overall have more firepower with the NUC.

Thanks, Peter

That is not normal. My files are served by Synology servers much slower than that (currently a ds115 and a ds109). But I do not experience any delay at all. Yes, you may take that literally.

Are you sure that your NAS is not performing any other very intensive tasks ? No networking problem either ?

Perhaps if Roon is still indexing and analyzing your library, this could introduce some delay. I don’t really remember, but even in that case I never had 14 second delays.

So, shortest possible answer : you don’t need to have a faster Nas. It probably has an issue, that needs to be resolved.

1 Like

I have now read two of your other threads here on this forum, and I think those contain some additional info that may be useful here :slight_smile:

First I should state : Roon will simply load the file, from your NAS. That’s it. It does no modifications, and puts no further strain on your NAS. It should, normally, be an extremely easy task for a NAS.

Second. It could indeed be that your core is still analyzing your audio data. This is pretty CPU intensive. And for 1TB worth of data, this is NOT something that will be finished in just ‘a few hours’ as you stated.
I would not expect this to cause such problematic delays, but it could be. If still analyzing, it would look something like this. Go to settings -> library, and see if something is being analyzed there :


If so : you can see two settings there, to either give the analysis less priority, or to disable it at all (for now). Try it, and see if it is snappy again. If so : just give the analysis the time that it needs to finish :slight_smile: .

Third. I see that you are struggling with an Always-on fan on your nuc. Could be please temporarily add a smallish (I’ve edited this in later!) watched folder on a USB drive, and attach that drive to your NUC (Obviously, disable watched network folders for this test). Is it now nice and snappy, or is it still lagging ?
If still lagging, it could be that the CPU in your NUC is having thermal problems (and thus downclocks itself). High fan speed, but no observed heat at all could be an indication of a heatsink with bad CPU contact. Would make perfect sense to me.

2 Likes

Thank you @Marco_de_Jonge! I am now away from home until friday, but I will check to see if roon is still analyzing. That was the clearest answer I’ve gotten about how to determine if it is still analyzing. I hope that is the case. If so, I will play with the settings.

I can definitely add a USB drive to my NUC and temporarily disable the NAS drive and see if it has an effect on lag times and on the fan-on issue. Good theory about the heatsink with the bad contact. That may take me a while to do, because I am having a music listening event with friends at home this weekend. I will report back!

1 Like

I can see by the way you worded your answer, that you understood me perfectly. Great !

Just to be sure : this should not have ‘an effect’; that sounds like the trouble gets less bad. After you added another (exclusive) USB watched folder, and disabled audio analysis, you should experience no delay at all. Well I understand that isn’t technically possible…but let’s just say that you as a human shouldn’t perceive it.

I’m confident that we can find and solve this problem.

Hi @Marco_de_Jonge. Just got back home and so far have only had time to check whether Roon is analyzing. It seems like Roon hasn’t done any audio analysis yet! I see no message, and I find that my “background audio analysis speed” is set to “off” (that was a surprise - I didn’t set it that way - but I purchased my Nuk/Rock from a friend!). Anyhow, if it’s not analyzing, it doesn’t explain either my fan or my latency issue. Thoughts?

If you have a library and can click on albums and see the meta data then roon is doing analysis.

Regarding the latencies> no immediate thoughts yet. Except for the proposed test with a watched folder on ONLY a USB drive. This could at least rule out an eventual networking or NAS issue.

(edit) Perhaps a silly thought, but as you did not assemble the NUC yourself : are you sure that is running on an SSD, and not a spinning disk ?

An additional test could be, to create such a watched (shared) folder on any pc on your network. This could, perhaps, rule out a possible networking issue that may be at the ROCK side.