Synology NAS, External SSD, & Sonos

G’day,

I signed up for the two week trial last weekend and have the basics up an running but have not been able to get any of 8 Sonos devices I have be detected by Roon Core, thus far the only two devices I can see are my iPad or iPhone when I open the app on each device.

My setup environment:

  1. Synology DS918+ NAS with 8GB RAM
  2. Brand new Seagate 500GB External SSD with RoonServer shared folder
  3. Roon Core NAS running via https://roononnas.org/de/roon-auf-nas/

When I open up the Roon app and go to Settings -> Audio I see the iPad or iPhone device listed correctly depending on which device I open the app on.

What I expected to see there were my Sonos devices, a Play:5(gen2), a Move, a group that consists of a PlayBase and 2x Play:3’s, or a group of two Play:1’s, but I don’t see any of these devices.

I’ve read that the DS918+ CPU might not have enough cpu horses to power RoonCore and I’m OK if this is the root cause of the issue, though I’m hoping its not.

So, even if the DS918+ lacks enough horses I would have thought that the Sonos devices would at least be detected and listed in Settings -> Audio and playback performance to any of those potentially less than ideal.

The only thing I’ve wondered is possible firewall ports blocking traffic between the NAS version of Roon not being able to detect the Sonos speakers on the network (p.s Some of the Sonos speakers are connected via LAN, others wifi) but I’ve not discovered any mentions of this whilst searching for a solution.

Any tips on what I might be doing wrong would be greatly appreciated

I’ve tried a few things since posting the above:

  • Tried disabling the Synology Firewall and restarting the RoonServer app to no avail.
  • SSH into the Synology NAS and I can ping the the Sonos speakers without issue
  • Tried opening up 6001-6010 UDP & 6011-6030 TCP ports for AirPlay to no avail
  • Tried opening all the TCP & UDP ports listed on Sonos FAQ here to no avail

Switched to an install of Core on my Mac and partially works:

  • The Sonos PLAY:1 is detected as “Sonos”
  • The Playbase and Play:5 are detected as “AirPlay” devices

Also maybe of use, I saw mentioned “jumbo frames”, I’ve got a Unifi network setup and 4 switches, have checked each of those and jumbo frames is disabled on each

I’ve grabbed a copy of each Cores log files (NAS and Mac) and will take a peek into those now

Hi @netweb,

Thanks for reaching out.

I would focus first on the Mac as the Core (to eliminate possible networking issues).

Grouped Sonos devices only show up as one, if you ungroup them do they all show up as separate devices?

Do you by any chance have Open vSwitch turned on in the Synology config? This setting has sometimes caused issues with Roon seeing devices on the network.

Flow Control is also an aspect you should be aware of. If your switches support this feature I would try turning it on. There are also some other great networking suggestions in our Networking Best Practices Guide which you may want to review as troubleshooting progresses.

I think the Mac is working as expected. it see’s the stand-alone and group Sonos devices

These all show as expected on the Mac, groups as a group, singles as singles so I’m fine with this

Will attach a screenshot of the Mac setup which is perfect

I couldn’t find this option in the Synology help, or looking in network settings, not sure if it relates to VLANs and VLAN tags, will have to go research this further

Done, turned that on, no changes to the state of Core on the NAS though.

The above is the Mac running Core with everything I can think of listed correctly, “Sonos Streaming” and “AirPlay” enabled for the devices that support both, and just “Sonos Streaming” for the Play:1 group that doesn’t support AirPlay

Thanks @noris, looks I’ll have to continue taking a look at the network settings as things only appear to being detected inside the Synology network side of things…

1 Like

Hi @netweb,

Glad to hear the Mac is working as expected. One other aspect to consider here - are you by any chance running any apps on the Synology that uses port 1900, such a Plex or Emby? If so, is the behavior the same if you temporarily turn the other app off and reboot the Synology?

I had Plex installed, though it wasn’t running and I haven’t used it in a long time, uninstalled it but no change

Thanks for the suggestion though, it reminded me that I have a few Docker packages running that shouldn’t have any port conflicts, have turned all those off to test and no change

I still haven’t peaked into the logs yet, but I’ll do that soon

1 Like

Thanks for checking that @netweb. If you are able to look over the logs and find the cause, great but if not please let me know your networking setup including model/manufacturer of your networking gear, perhaps that might be a factor here.

Thanks @noris, it’s all Unifi, USG3 Router, CloudKey Gen2+, US-8 & US-8PoE60w switches

Thanks for the info @netweb. I would also suggest you make sure that multicast is enabled on the Synology and networking gear as Roon uses multicast for device discovery.

I have just solved my own similar issue. Synology 918+, Roon Core on SSD in synology. UniFi network & Sonos.

First issue was Open vSwitch, it is a function used for the DSM Virtual Machine. Luckily I am not running any VM’s on the synology so I was able to Uninstall the DSM VM app. Second issue was that I use Link Aggregation bonding which i had to turn off. Once those two items were dealt with I was able to turn off Open vSwitch on the Synology in ‘Control Panel’ -> ‘Network’ -> ‘Network Interface’ -> select your active network interface -> ‘Manage’

Now I can see all of my Sonos speakers and Apple TV’s.

I decided to check out Roon after giving it 3-4 years to mature and did not realize Sonos could be an endpoint. I had already set up ropiee with a digihat before i realized the sonos option. The next venture for me is figuring out how to implement MQA unfolding and DSD stuff.

Hope this helps someone!

EDIT After reading the network best practices faq I saw that IGMP Snooping should be enabled. I Already had IGMP Snooping in the UNIFI Controller turned on for some Crestron NVX Multicast fun.

3 Likes

Thanks for this post, I searched for a very long time. But no more virtual machine … boring

Thank you! Turning this off completely sorted this same issue for me.