Synology NAS mapping to Roon

I’ve been successfully using Roon. The Roon Core is on a Linux-based SonicTransporter. When I switched routers to a netgear Orbi, I lost the mapping.

Now after following everything I could find on the forums here, I can’t map Roon to my NAS. The support files are comprehensive but quickly devolve into jargon beyond my comprehension. Like what is the network share path and how do I find this?

Can you point me to some low level instructions where a novice can follow?


Hi Larry,

I moved this to the Support category and will flag @support for you. Someone will be along to help.

Cheers, Greg

Hey @larry_green — Thanks for reaching out!

If you haven’t seen our NAS FAQ I definitely recommend checking it out!

How do you have your SonicTransporter and NAS connected to the network? Are you using an Ethernet connection for both? Are they both directly connected to the main router? Are you able to see both of these devices over the network from another machine?

Can you share a screenshot of what you’re adding in Roon that isn’t working for you?


1 Like

Both to Ethernet. Both seen on network

Thanks for the update, @larry_green.

Since everything is seen on the network let’s take a closer look at what is being added in Roon:

  • Can you share what you are including when you go to Add Folder?
  • Are you including the username and password?
  • Can you confirm that the folder’s share settings are correct (i.e. the folder can be read by the username and password you’re using for the connection)?
  • Can you confirm that you can access the media in that folder outside of Roon?


That is my problem. This is the part I don’t know what to add. My music is on a Synology NAS, and in a folder called music. What is the path I point to? See screen shot where I am stuck

I spoke to Synology and they insist my network path is:\music. However, this doesn’t work. See screen shot

Never mind. I didn’t add \ in front of path. I think it works now

Hey @larry_green,

That’s great to hear! I’m glad it’s working for you now. If anything else comes up please let us know and we will be happy to help.

Happy listening!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.