Synology NAS not authorised

I’m running Roon Core on a brand new Mac mini and I have my FLAC library on a Synology DS216j NAS. I’m trying to use the Settings/Storage/Add folder/Add Network Share function to locate and add the NAS as the source of my music. I have tried to do this via both the smb and MAC address methods shown in the knowledge base. Roon seems to locate the NAS music folder just fine, but it returns an alert in a red box: Could not connect to share: Unauthorized

I’m assuming this is a permissions issue in Synology Diskstation, but I don’t know where to look. I have tried to install the RoonServer .spk file downloaded from Reike’s blog site, but that was incompatible with my (latest) version of Diskstation.

Can anyone @support help me with this?



@Scott_Garrett Scott if you have the Core on your mac then you don’t need to install anything on the NAS to have roon connect. Its often easiest to have the NAS as a fixed IP address and add that as the network share as detailed in the KB pages here

Many of us here use Synology and QNAP NAS’s and there is no issue. but the connectivity and login has to be correct on the NAS


Thanks Wizard…greta to get such an early response. I tried your suggestion a few times and Roon sees the NAS, but here’s what I get in response (see screenshot)

For Username if you can set up a specific roon account with the read only permissions (if you are paranoid) for the music share only and a decent password and try with that. Do this on the synology control panel under users

Hi @Scott_Garrett,

Does that path work when using Finder or File Explorer from a Mac or Windows machine?

Are there any special characters in the password? If so, can you try changing it to something that doesn’t use special characters?

@wizardofoz your solution worked. I set up a Roon user account on the Synology control panel and it worked immediately. What I Doni’t understand is… why? At any rate I’m grateful for your help. Thanks a lot!!

1 Like

Thanks @Dylan… seems I’ve managed to get it to work by following @wizardofoz advice to set up a separate user account on my NAS control panel. Weird… I need to work out how that was a solution. There are no ‘funny’ characters in my password btw

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.