Synology Network Share [Resolved]

I’m on the trial version and tried to connect to my NAS but I’m getting a message that access is unauthorised. I have entered the correct username and password; I’ve tried a couple of my accounts that I know to be valid - access via finder and iTunes is fine.

Running High Sierra on my Mac. SMB3 enabled on the NAS

Thanks in anticipation.

You need to allow smb1 connections I think and you will need the share to be smb://your IP address not afp://

Yep got that. Minimum of SMB1 maximum of SMB3 on the NAS and using smb in the network share address. Or are you saying I need to set in SMB1 only? If it becomes a time consuming exercise to get the trial running then I’ll probably stick with iTunes or look at alternatives.

Can you post a screen shot? I am using a very similar setup with no issues. Mine goes something like this


and then the Music user and password. I do not use the SMB stuff or IP address…


Where is Roon installed ?

Yoy can access Roon, as well as Tdal inside Roon ?

Your only problem is to access local music ?

I’ve tried a variety of options including NAS name, IP address, with and without smb prefix, different NAS accounts including admin.

Are you running an encrypted connection?

Roon is installed on my Mac. I’ve not tried Tidal but I don’t believe this would help with the failure to be able to add a network share for my NAS

Hi @Graham_Jones ----- Thank you for the report and sorry to hear of the troubles here.

Moving forward, to help aide in our understanding of why you are experiencing this issue with the mentioned NAS may I very kindly ask you to please provide the following information:

  • Please provide the make/model NAS you are implementing.

  • Please confirm that you can access the NAS without issue from the OS level on the same computer hosting Roon.

  • Please provide screenshots of…

    • The “add network share” window when you encounter the mentioned error message. I want to see how you are trying to add the network share in app.

    • “Sharing” settings being used on the NAS.


Roon Knowledge Base - FAQ: I’m having trouble setting up my NAS

Hi Eric,

Thanks for spotting the post. Answers as follows:

  • Make/Model: Synology DS1515+

  • Absolutely no problem in accessing the NAS folders in Finder

  • Screenshots as follows:



@Graham_Jones ---- Thanks for the follow up!

Can you also share a screenshot of the “advanced settings” window under “Enable SMB service”?


Hi @Graham_Jones ----- Touching base with you to see if any progress has been made here. Let me know and if further assistance is still needed I will be glad to lend hand.


Hi Eric,

Apologies but offline all day. Here’s the screenshots



You wrote //192…

I think it shall be \\192…



Now got this working. I created a new user with only read only access to the music folder on the NAS using a simpler password than that suggested by Safari and it all worked.

Thanks for all the suggestions.

This topic was automatically closed after 32 hours. New replies are no longer allowed.